Zero phase images resulting from TOPS InSAR

Hello there,

I am new to Snap and to this forum. I am attempting to use SNAP from the GUI for interferometric processing, but ultimately I will implement it to Python using Snappy. I have been using this tutorial as a test:

This problem looks similar: Error in phase and coherence band at TOPSAR Correg Interferogram

However, the for me the zero phase image only appears after interferometry:

The intensity image after interferometry also looks wrong:

The coregistration looks just fine:

Only I find the phase image in the coregistered product odd, as one can clearly distinguish land from see and it should be a noisy image.

I also see a processing artefact. I have debursted and multilooked the coregistered image and the interferogram to be able to view it on my notebook.

I have tried this with two different data sets, first not following the exact instructions and then with the tutorial. I have also updated SNAP to the newest version 7. My OS is Ubuntu 18.04 LTS.


Could you provide the names of the two input products?

Thanks! I realize I made a mistake indicating the master and slave image. In the processed data I now find the same dates on the coregistered products. However, on the data I attempted processing with earlier, where I got the same result the dates are correct on the master and slave image.

A comment to my post above, the phase image is irrelevant. I came to conclusion the distinction land/sea comes from a mask and the artefacts are induced by multilooking.