Amplitude Dispersion error

Dear all,

I’m stuck with the mt_prep_snap step in my virtual enviroment.
It’s tellig me, that 200 does not exist. The Stamps manual isn’t very helpful and I couldn’t find any ideas to this problem.

My guess is, that some stuff in the config is wrong.

Thanks for any solution and explanation!

best regards

simon


StaMPS_CONFIG.bash (1.9 KB)

I think it’s because you have a space in your data directory path. This is making it think EXT/ba/project/INSAR_20200326 is a separate argument. So then I think it is thinking that the “200” value is the maskfile argument which does not exist.

Try putting your path in quotes or replace the space with an underscore.

3 Likes

Thank you, I did not thought of this.

However executing the command now gives me alot of errors regarding opening the files. But it does create the Patchfolders for me in the master directory. I"m confused again.

Try taking a look at this thread:

1 Like

I am not getting how to meaning environment for amplitude dispersion . Terminal saying command is not found

Did you modify StaMPS_CONFIG correctly?
Please carefully follow these instructions. The step on TRAIN is not necessary, but optional.

oky sir , thank you

sir we install SNAPHU and cygwin for UBANTU alternative but still we are facing same problem

Sorry, but it seems that you are randomly pressing buttons. To get StaMPS to run

  • install StaMPS (this does not always work under Windows)
  • have your data structure correct (SNAP export in one folder, then navigate to working folder)
  • enter the correct paths in StaMPS_CONFIG and source the script as described in the manual
  • execute mt_prep_snap correctly including the reference date, the location of the SNAP export directory and the variables on amplitude dispersion)

A summary is given here: StaMPS - Detailed instructions - #2 by ABraun

Hello, I also got an error.
sneg@Avrora1:/mnt/f/O_Borly_2021/Insar_master_data$ mt_prep_snap 20210910 ~/O_Borly_2021/Insar_master_data/ 0.4
mt_prep_snap: command not found

I understand that I did it wrong, but I can’t fix it. the instructions say
“6-2 if you install the STaMPs and edit and source the bashe file but still the mt_prep_snap doesnot work, you can check the same command when you are in the stamps bin folder path. In that case, the path to stamps bin folder should be added to the main .bashrc file in WSL root folder in order to make it available from every path.
Wsl root folder:
I put my own WSL path as a sample here
C:\Users\tech\AppData\Local\Packages\CanonicalGroupLimited.UbuntuonWindows_79rhkp1fndgsc\LocalState\rootfs\root
Yours should also be in a similar place
6-3 so similar to what we have done before for stamps bash file, here, we also have to edit the .bashrc file with nano or vim editor”.
But I can’t figure out how to do it. Can you please tell me where I can read about it?

Здравствуйте, что-то опять не получается. Подскажите, пожалуйста, где я допустила ошибку?

Apple translation: > Hello, something is not working again. Could you please tell me where I made a mistake?

You show a PATH setting in .bashrc.save. When you adjust the PATH you can check that the change is working by running “echo $PATH” in your terminal. Note that .bashrc often has different sections for interactive sessions and batch scripts, so you have to be careful of which section you change.

Thank you very much, but still don’t understand how to solve my problem. Should I try reinstalling Stamps?

It appears that your problem is lack of basic linux concepts and procedures. Stamps assumes that the user has some basic linux expertise. There are many sources for linux training in many languages. I recommend https://linuxcommand.org.
The website is available in book form (in English) and is also available in the following languages:**

Many libraries have the book.

I am a postgraduate student, I just need to try one metod i need single images processing to test the method, but I have been suffering with this for 4 months. I do everything according to the instructions. The programmer is sitting next to me, but he does not understand what the problem is. In any case, thanks for the advice.

We can’t help if you don’t tell us what you don’t understand. The information you have provided indicates that you are not using the value of the PATH variable needed to run mt_prep_snap. Setting the PATH variable is a basic linux operation that users are expected to manage. This is a linux issue and is off topic for this forum.

2 Likes