Apply orbit file error in S1-TOPS Coregistration

Hello all,

I have been trying to do TOPS coregistration but an error with the orbit files always appears:


Any suggestions?


Is your SNAP updated?

Is your machine connected to the internet?

Does this error appear when you try up only to apply orbit?

I suggest to you , apply TOPSAR split, and then apply orbit for each single image separately and let’s see the result,

Yes, SNAP is updated, and my computer is connected to the internet. I even checked internet velocity:

I tried what you suggested but there is another error:



Once you applied TOPSAR split followed by apply orbit, No needs to reapply orbit once more,
I suggest now to apply the step individually,

TOPSAR split -----apply orbit---- backgeocoding---- ESD----

In case everything went right, something is wrong with your previous TOPSAR corr. But if you like share the identify name of the images, I’ll check up,

The error you getting gives me the implication you are not using SLC data or you have already split your product and trying to do it again.

No , they are SLC , but as I mentioned and you noticed same thing, she applied same operator two times.

Indeed i see the name of the product now, my bad.

Ok, I was repeating steps, thanks.

So, I split the data individually and applied orbit, but a new error appers:

The same with the other file.

The data downloaded is:


Is a step missing?

Thanks, anyway.

Check this post, meanwhile I’m downloading your two images to see what is wrong, and I’ll comeback to you,

problem occurred during target product initialization

here is the result one of your product,

And here is the second product,

Hope it helps,

1 Like

About the post you shared to me, I wonder if I should do a processing before split the image? I have read many posts about DEM generation procedure, and I think I’m not missing anything.

I know where the problem is looking at the images you shared, split is not correct:

The displayed image is the split data

It´s complete, because I can´t select bursts:

Could it be hardware capacity? My pc is Intel Core i7-4790CPU 3.60 GHz 16.0 GB RAM, Windows 10, 64 bits. SNAP version 6.0.

you select the bursts here by dragging these triangles towards the middle


Additionally, for InSAR I recommend using VV only. Here is why: Effect of polarization on interferometric products

The bar can not be moved … I tried several times with both buttons.

Ok, I selected VH by mistake.

That is strange, I have never heard of something similar, sorry. An example is given here: (at 14:45)

You can try to coregister the images directly in the S1 Coregistration Tool. It combines Split (try to move the buttons there), orbit file application, BackGeocoding (use SRTM 1Sec) and ESD.

1 Like

In the following post you could find more details about DEM creation,

Source of the post

I have similar machine it works well for me, However I’m intending to increase the RAM to 32 GB,

Is still this the case? IF yes, might be you missed the update of your SNAP and it affects, from the Help tab you could check up for updating, in case it does’t work remove the SNAP, and reinstall it once more,

I agree totally with our colleague @ABraun that VV polarization is the best option and it gives better coherence, I checked up this also from my personal experience, But you said

It’s not mistake, I think you could apply both to disclose the differences yourself.

1 Like