Atmospheric correction using Sen2cor

I am using SNAP 7 and Sen2cor 2.8. While I am trying to perform atmospheric correction using this toolbox the process terminates in halfway through giving the errors attached. Use of sen2cor not only spits out this error but different errors in different times. I am so stressed with this toolbox. Can somebody please help me? SNAP1

does this happen with every product you use or just with one specific?
did you apply any pre-processing to the image before running sen2cor?
maybe you changed the name of the product folder or removed some of its contents?

I just unzipped the downloaded product and applied the correction. If I do the same operation with sen2cor255 it says my file is not in .SAFE format. It is happening with all the products I am using right now.

have you tried calling L2A_Process (of version 2.8) from the command line? If both are installed, maybe SNAP mixed up the two instances.

I am not doing it using the command line but can you suggest me a good version of sen2cor for processing 2018 and 2019 images?

both 2.5.5. and 2.8 should work actually. To find out if there is a problem with the data itself or if it is related to SNAP, you will have to check in the command line once. It’s not that hard, simply open a command window in the folder and enter L2A_Process as well as the S2 directory (S2*.SAFE), at best with full paths.

I couldn’t do this . Do you have a demonstration on this? Sorry about that.

Open the shell window in the folder:

Enter the command as explained in chapter 4.4.1 of the manual:

There is also a video of this:

1 Like

Hello @rajeev.bhattarai

This is what I do. I apologise, but I’m a Windows user :smiley:
I cd into the drive where my Sen2Cor is (Y:)
I then cd into the Sen2Cor folder
I then press ‘L’ on my keyboard. This brings up the L2A_Process.bat file on the command line.
I add a space and then drag and drop the L1C SAFE folder onto the same line

My machine (not the quickest in the World…) thinks a moment, and then does its thing.



1 Like

I just want to add to Jans nice explanation: Instead of copy or drag the path name, you can also use use the tabulator key to auto-fill existing paths and files. So you don’t need to enter long names by hand.

1 Like

It doesn’t work in command line also. The command runs for like more than 30 minutes but doesn’t give anything. The error it shows is attached.

30 minutes is not unrealistic.
A new folder L2A should occur in the same directory of the input dataset

According to this post, this error occurs when the path name is too long. Try putting the original data in a simple folder, such as C:\temp\S2*…

It solved my problem now. Thank you.