Authentication Issue - Organisation Level


Note: This issue is similar to the following post but I dont think it has been resolved - it did not work for the users with the problem

SNAP 6.0 First Start: Authentication Required

I have given a demo of SNAP to two large spatial data organisations here in Ireland - Copernicus data, plus processes in SNAP. They both are interested in trying it, but both have had the same authentification issues which has stopped us from going any further as cannot be used internally.

SNAP works fine on wifi but once on their network - it hangs and must be killed in task manager.

We have tried

  • Multiple installs
  • multiple PROXY configuration profiles
  • checked all urls in C:\Program Files\snap\etc\ file and they are not blocked
  • checked messages.log and there are no errors
  • no SNAP errors in the Windows Application Event log.
  • Tried editing C:…AppData\Roaming\SNAP\config\Preferences\org\netbeans\ file. Changed proxy to the IP address and explicitly added username and password to the file. Used different username syntax

No luck at this stage - any suggestions? These are exactly the type of organisations we would like to get using Copernicus data.

I’ve found corresponding issues in NetBeans and Java.

The issue [Netbeans-58] NB IDE or NB Platform freeze on startup (proxy with Negotiate auth) describes the problem very well and states also possible workarounds.

As I have no chance to reproduce the problem it would be good if someone would volunteer to help trying out the workaround #3. I will later build the plugin. Would be good if someone can give it a try.

It seems that we can’t fix correctly it without the help of Oracle.

Other links:

Attached is the plugin. You should be able to install it following the instructions:

I tried it myself and looked at the code and it is not doing anything harmful, as far as I can see.
But I can’t say if it fixes this issue.

Update: I’Ve also created an issue for this:

1 Like

Hi marpet - thanks for looking into this so quickly. I cannot see the attachment, can you please reupload?

Ups! It seems I forgot to attach it.
Here it comes:
nbnetauthenticator-1.0.4-SNAPSHOT.nbm (24.3 KB)

1 Like

Seems to have solved the issue, thanks marpet.

"The plugin worked. I had to un-install the application first. After the re-install and first run of the application I installed the plugin, restarted the application and then installed the updates. I’ve opened and closed the application over 5 times and all is good. "

1 Like

That’s good to hear.
Even this solution is not optimal, at least SNAP is usable.
We could think about integrating it directly in SNAP for the next release.

1 Like

I think that is a good idea and would be very useful - the plugin doesn’t install for all users so currently each user needs to install the network authenticator plugin.

This plugin is still needed when working behind a corporate proxy system. Is there any update on integrating this fix to SNAP, or on some more upstream fix?