Blank Image After Terrain Correction

I am new to snap. I have downloaded sentinel 1 image from ESA. I have performed radiometric cal-liberation as well as speckle filtering. After that, when I tried to perform terrain correction, the processing was completed within few seconds and the output obtained is a blank image as shown below.

Can anyone please help me out in this matter?

The URL to the default SRTM 3sec dem has changed. In the Tools->Plugins menu, update to the latest version 6.0.6 to be able to use that dem.

Thanks for the reply. I have done the changes as per you mentioned. But still it seems the problem is not solved as the processing gets completed in few minutes and as a result the image obtained is not erect.

these parts indicate that elevation was used

You can change to SRTM 1Sec to use a DEM of a spatial resolution of 30 meters (instead of 90)

Thank you :slight_smile:
Can I add one more question that is it necessary to choose map projection UTM/WGS 84 Automatic or use by default option WGS84(DD)

WGS84 (DD) projects your data into geographic coordinates (based on decimal degrees) on a spheroid
UTM/WGS84 (Automatic) projects your data into UTM coordinates (based on meters) on a plane

The result is the same, it’s simply a matter of what you want to do with the data later.

Thank you :slight_smile:

Could I ask a question? When I used the POD Precise Orbit data to perform the terrain correction for the Sentinel-1 images, I found that the corrected result always has a few pixel deviations compared to the standard image. However, when I used the SARScape tool in ENVI to perform the terrain correction, there is no deviation between the corrected results and the standard image. Can you tell me what the problem is?

Terrain correction uses the orbit state vectors. If the inputs have changed then the results should change too. The question is have the results improved or gotten worse? Could you provide the name of the S1 product and a GeoTiff of the SarScape result?

Hello everyone, I have been trying to run the Terrain Correction function on two Sentinel-1 images. I have had the same problem with blank image. I’ve done all the updates for version 7 and, unfortunately, nothing went right. I also tried external DEM and it didn’t work.
I un-installed SNAP 7 and installed version 6. After all the updates … I still have the same blanck image problem.
What can I do?
Thank you very much in advance!

Can you please try Average Height Range Doppler? If this produces an output then the retrieval of the DEM is the problem.

Thank you ABraun! I processed what you told me and sent the prints for verification.

What can I do?

very strange. So it’s not the accessibility of the DEM that causes the empty files.

Can you please check if the data contains correct pixels after calibration?

Hi everyone, I have the same problem as marcelo, have this problem been solved? Does anyone know the reason?

please describe what data you were using, which steps you applied and when the problem occurred.

Thank you! I use the data of ALOS2, and after radiometric cal-liberation, speckle filtering and polarmetric decomposition(also tried without the last two steps), I use the terrain correction, but the results is blank, and the pixel info is Nan. I changed different Dem, such as SRTM 1Sec, and other external dem, such as SRTM1 v3. I have tried Average Height Range Doppler too, and the problem remains.

have you checked if the data is alright after polarimetric decomposition?

Thank you for your reply. Yes, it’s fine after polarmetric decomposition.

there are currently problems reported related to the automatet retrieval of DEM data. But this could be something different, as you said to have tried an external DEM as well, right?

Are you using the latest version of SNAP?

Yes, I have tried external Dem, and also ellipsoid correction, which does not need Dem, and also blank. I am using the lastes version of SNAP.
Or, are there any problem of my data?