"bound must be positive" error in the Random Forest Classifier


#1

Hi, I’m new in snap. I want to do a supervised classification with Random Forest Classifier but when I execute the tool I receive the notification “bound must be positive”. How can I solve this?


#2

reproject your data to WGS84 (uncheck “reproject tie-point grids”) and try again. Somehow, the classification module cannot handle UTM coordinates.
See here: Rndom forest classification steps


#3

It worked, thank you very much!.

Kind regards


#4

@Misio

Hi, I am working with SNAP to classify crops. I got same error(“bound must be positive”).
And I tried to do what ABraun said as rectification(uncheck “reproject tie-point rids”). but I am unable to find this option can you please help me in this ?


#5

Raster > Geometric > Reprojection
Select Geographical (lat/lon) WGS84 here.