Current Geo-coding Cannot convert from geographic to pixel coordinates + SNAP batch processing not outputting files with different names

Ok, So I have snap installed on two computers, one is my own personal and one remote desktop.
I have made a graph to batch process SLSTR RBT products (I have downloaded the data for past 3 years) and now I want to extract the Brightness-Temperatures bands in a form of CSV.

The problem is the unexpected output of the Snap batch processing tool. On my personal PC, It runs fine and does not give me any errors except for the fact that it is not outputting all the files but saving only one file (more like overwriting the same file again and again).

On RDC, it runs but gives me the following error of Current Geo-coding…
I am also attaching the graph below.
Currently I am trying to run it using only two product files…
mygraph4.xml (5.5 KB)

![image|690x456] (upload://abjKDsGurByXZtASQ2zdBRVttS8.png)

I have seen in your script that the name of the output file is written. This is what is causing the overwriting. Have you used this script in the gpt or are you only using the GUI?

I am only using the GUI. The output file is pre-written once I load all my files.

However, I have found what mistake I was doing. The area of which bands I wanted to extract, was not lying inside the main image and maybe that is why its giving me this error.

However, Now I am encountering the following error. Do you have any leads why is this occurring?

For the first 5 files, i think my shapefile area is not lying inside the product. But I can’t quite understand the other Source Bands error :confused:

If you go to SNAP preferences, check that the" Read Sentinel-3 SLSTR L1B products with per-pixel geocoding instead of using tie-points" is on.
Ok, I need to understand what you are doing. What I guess you want to do is to extract pixel values on Rawal Lake?
If so, first I had to resample the image to be able to mask to the vector: resample - vector import - land/sea mask.
In your graph you are doing it twice. Why do you subset if you are already working on the vector area? If your AOI is the lake, you could build a geometry around it and then use it as a mask in the land/sea mask to get the lake pixels only,

Exactly. I am trying to extract band values at Rawal Lake.

I tried first to only use my shapefile instead of subsetting it first, and it outputs an empty file while giving the following error:

And thanks for that quick tip of setting the preferences to per-pixel… I am re-running the batch process again to see if I can see any changes…

Ok so I clicked that check box “” Read Sentinel-3 SLSTR L1B products with per-pixel geocoding instead of using tie-points" and rerun the graph… but I am still receiving the same errors.

Not all products contain the band x_cn.
So, if you require this in the subset operator the error is caused.
The C-stripe has been disabled in January last year.
See the processing baseline:
Sentinel-3 SLSTR Processing Baseline - User Guides - Sentinel (

1 Like

I have excluded all of the bands which even contained the letter “c” in them from the subset of the graph. Now I am receiving the following error…

Probably those bands are also not present in the data products.
However, I don’t know the rules when they are included and when not.

Have you tried to do the process on the GUI with one image? Is it working ok? It was working for me when I replicated it. I will try with the batch processing and go back to you later.

Yes I have tried doing it with one image… I get the same errors…

The F1_BT_in have been replaced by F1_BT_fn.

This change have happened early last year.

That the subsetting worked for Ana is probably that Ana started fresh and the the F1_BT_in wasn’t considered. For kumailkhan1 it fails because he starts from the graph xml.


Hi, Marpet. I did some testing and debugging, and found out that some of my downloaded files are corrupted. So I downloaded some of them again, excluded the F1_BT_* bands from them and run batch-processing again.

I would like to ask if its normal to have abnormal values for some BT bands as shown in the picture while other ones being normal.

Also is there any way to convert Brightness-Temperature to real land temperature.

Regarding the validity of the values I can’t help.
If you are interested in LST you could use directly the L2 data.
Level-2 LST product type - Sentinel-3 SLSTR User Guide - Sentinel Online - Sentinel (

You can find out more about the data in the document library.
Sentinel-3 SLSTR Document Library - Sentinel Online - Sentinel (
There you might also find the answer to the value question.

1 Like