Doris5.03 stamps stamps

maybe you should select only some bursts in the TOPS Split operator to reduce the size of your product.

1 Like

if you work with an entire IW you should use many patches,
StaMPS suggest a single patch containing max 2million PS candidates (or you will get memory issues).

3-4 burst could work with 9-16 patches depend on the specific case.
Full IW (9 bursts) should have x2 or x3 number of patches (in my opinion)

I hope this helps

1 Like

thank you so much I’m doing the process again with 4 bursts, but I’m facing a problem while making interfergoram:
I don’t get this message via snap on windows but it takes so much time
how can i fix this problem?

this is memory-related. Your computer does not have enough RAM to process it. So it’s better to compute it on windows (more RAM here?) and wait until it is finished.


It might be also related to the parameter -Xmx specified in the configuration files. This value should be always a bit lower than the available RAM.

I hope this helps


thank you @ABraun and @mdelgado
I did the process with less number of bursts and I increased the number of images so i could have more interferograms and better number of PSs
but i’m facing the problem in stamps(1,1) again

I also face this error for mt_prep too:

would you please help me with this problem?

I hope you updated the ps_load_initial_gamma script.

ouh! sorry… are you using doris?
In such case it should be using ps_load_initial.m and not ps_load_initial_gamma.m

no I’m gonna use psi method by snap and stamps
would please help me with the “the ps_load_initial_gamma script” ? what should I do?

well… then you are posting in the wrong post.
it should be somewhere here in the blog.

Here you have it: New StaMPS release (4.1-beta)

You need to make a backup of the current one found in the stamps/matlab folder and put this one there.