Error in batch reprojection

When I use the module of batch processing, I want to reproject multiple TIFF files (EPSG_ 3395), these files are exported from the original data of sentinel 3 OLCI, but there are an error. However, when using the reprojection module alone, no error occurs. Because I have too much data, I can only batch processing。How to solve this problem (as shown in the figure below)?



image

As an alternative for batch processing in the GUI you could do it on the command line. There is a guide which explains this and provides a script to start from…

Bulk Processing with GPT - SNAP Wiki

Can you show the configuration of the reprojection operation?

Thank you for your reply. I have tried to use the command line to do this, but there is a problem. I don’t know where the problem is. I will attach the document.task.xml (2.5 KB)
I used the following command
gpt “C:\Users\64173\Desktop\task.xml” -Pfile=“C:\Users\64173\Desktop\1\S3A_OL_2_WFR____20160912T074412_20160912T074610_20171103T100608_0118_008_306______MR1_R_NT_002.tif” -Ptarget=“C:\Users\64173\Desktop\1.tif”


But there was an error. Can you help me see where to modify it

This error indicates that you don’t have enough memory.
How much RAM do you have?

Regarding the issue you experience in the GUI.
You can replace the WKT of the CRS just by EPSG:3995.

oh,I only have 8g RAM.
I saw the following prompt and thought it was a code problem. I can be sure that I wrote it according to the instructions.


I don’t quite understand how to replace the wkt of the CRS, because the image is in the Arctic, I have to use the EPSG:3995.
Can you give me some tips or documents to let me know how to replace WKT.

The problem might be that you have specified the target width and height. You can probably image that an image of 135 million x 116 million pixel is too big.
But even with less pixels you are at the lower end with your system. If you can I would suggest that you update it.

I’ve updated the xml and attached it. I removed the width and height and and just use the EPSG code for specifying the CRS.
task_update.xml (1.5 KB)

Thanks for your help, I tried your XML, but the same error occurred. I think it’s the memory, but after reusing the computer with 16g of memory, it still doesn’t work.
I’m trying to do something else.
Thank you again for your reply!

If you now have more memory, also the configuration of SNAP needs to be updated. You can either reinstall SNAP, then it is done automatically, or you updated the gpt.vmoptions file in the bin folder of the installation directory. And there you change the xmx-value to:
-Xmx11G

For the SNAP Desktop you need to update the snap.conf file in the etc folder. Change the xmx-value too. It is contained in the default_options parameter: -J-Xmx11G

Oh, it turns out to be frustrating. I’ve changed the settings according to your instructions, but it’s still the same error

Hi, Marpet.
I think this is a bug because I use a 64G computer to process images that need to be reprojected. When I use snap’s GUI, it tells me “this AxisDirection object is too complex for WKT syntax”.
Later, I used GPT to process images, and it ran out of memory. I think 64g of memory is enough.
Strangely, I used snap’s re projection tool to convert the projection to espg3995, which could succeed, but the batch process could not, either GPT or batch process toolbox.
I see that you also have such problems. Have you solved them?


I need to process too many images. I need your help

Can you provide me 2-3 names of the original product files? Could you also send me one of the tif files?

I’ll send you a PM with the upload location.

The reason for the memory is that the output parameters are not correctly set.

image

You specify the easting/northing and the pixel-size in degree. But it needs to be defined in meters. The unit of the target CRS.
I haven’t noticed this when looking the first time at the graph.

So a pixel-size of 0.012 means a resolution of 1.2 centimetres and this results in a huge target image which does not fit in memory.

So, I would suggest that you try this graph first:
task_update2.xml (1.4 KB)
If it works than add the desired pixel size in meter and as last step add the easting/northing coordinates but also in meters.

I’ve also disabled the reprojection of the tie-point grids. I think they are not necessary in the resulting product. But you can enable them again if you like.

Thank you very much for your spare no effort to help me solve this difficult problem. It’s true that there are some problems with the chart I wrote before, and the exported memory is out of memory. After that, I studied the XML file carefully and made the following modifications, and attached the code to help people who are also experiencing this problem. myGraph.xml (2.2 KB)
code:for /r "E:\2018" %X in (*.tif) do (gpt C:\Users\64173\Desktop\myGraph.xml -Pinput1=%X -Poutput=" E:\re2018\Re_%~nX.tif")
This code can batch re project all the files in a folder. If you need to re project to other coordinate systems, you can modify the wkt file. Similarly, you can change the file types that need batch processing, such as envi, HDF, etc. it should be noted that you must modify the file path to ensure normal operation
I think developers should solve this problem better in GUI interface, so they can save more time to study other things. I think developers should better solve errors such as “this AxisDirection object is too complex for WKT syntax” in the GUI interface
All in all, thank you for your timely help!