I am trying to run speckle filter on Sentinel-1 SLC data. I have generated a C2 matrix from the data and have then carried out multilooking. After that I applied Lee sigma speckle filtering with a window size of 5x5. After running the tool, I get the error::java.lang.NullPointerException. I have tried using different filters but all of them give me the same error. I also tried speckle filtering over the C2 matrix, however even that gave me an error. Can anyone please tell me how to resolve this error?

When reporting a problem you need to provide enough detail to allow others to easily reproduce your issue, in particular, your OS, SNAP version and update status, input data, and processing steps. The Step Forum FAQ has useful advice. It is much more helpful if you can copy text from a window and past as text in forum posts because images are not “searchable”, so the next person with the same error may not find your post.

java.lang.NullPointerException has numerous underlying causes, so you need to look deeper to find the underlying problem. There may be more information in the messages.log file or OS logs, but without knowing your OS we can’t tell you where to look.

1 Like

I am using Windows 10 ,SNAP version 8.0.8. I have used Sentinel-1A SLC dual pole VV,VH data acquired at IW mode. I had used the following steps:-
1.Orbit File
2.Radiometric Calibration (Complex)
3.Tops De-burst
4.Matrix Generation
While carrying out the speckle filtering, I was getting the error java.lang.NullPointerException.
After using the Polarimetric Speckle Filter option, the issue was rectified.

1 Like