Error: No valid tiles associated to product [MTD_MSIL2A.xml]

Dear all,
I am trying to open the product of Sen2Cor tool (a Level2A product of S2) using SNAP but I got this error ( No valid tiles associated to product [MTD_MSIL2A.xml]). I am using SNAP is 6.0. Can you guide me how to open and display the image?

Update: This problem was solved after “updating” the SNAP 6.0 and “restarting” it. Thank you!

2 Likes

Thanks. It worked for me too. I just had to restart SNAP and could open the product.

Hi,
I have similar problems with you. I have my SNAP version 6.0 already. But I still have the error as you. Should I update SNAP to a higher version? Could you tell me more details? Many thanks.

Menu > Help > Check For Updates

Thank you! Yes, I can load my data with your method!

I still can’t open the product after updating the SNAP 6.0 , it shows the same problem" No valid tiles associated to product [MTD_MSIL2A.xml]". Could you guide me how to solve it?

Have sen2cor been properly processed? if yes, what is the reason beyond open?, Which process do you intend to implement?, How do you open the .xml?

First check up if you could open the result of L2A in SNAP,

Thanks for your replay, I have solved it after updating all toolboxes.

hello i have the same problem but not with 2A but with MTD_MSIL03.xml the project was generated with sen2three 1.2.0 in command line because the plugin doesn’t appear in the plugin tab to install in snap and it says that finished successfully my snap version is updated to 7 and all the toolboxes are updated too, i tried reprocessing several times with different resolution but it doesn’t work, i really appreciate your help

do you store your data in a directory with a very long path maybe?

that’s absolutely true i’ll try in a shorter path and i’ll say you what happened thanks

no, it doesn’t work i reprocess the project in a shorter path D:\data\ it finishes correctly but the error continues

Sin título1

sorry to hear that. I have no idea then.

thank you anyway