Error of Interferogram in SNAP


#1

Hi everyone!

I don’t know why, but whenever I want to run Interferogram in snap, it shows an error about Operator Exception. Could you guide me please?

Thanks


#2

We need a bit more information:

  • what data are you using?
  • what were your previous steps?
  • can you post a screenshot of the product that is used for the interferogram module?

#3

Maybe one of the tutorials helps http://step.esa.int/main/doc/tutorials/sentinel-1-toolbox-tutorials/
If not, we need some more information indeed. For example the full message of the error and those things what @ABraun already requested.


#4

Hi

this is the full message:

org.esa.snap.core.gpf.OperatorException: Interferogram: java.lang.NullPointerException
at org.esa.snap.engine_utilities.gpf.OperatorUtils.catchOperatorException(OperatorUtils.java:391)
at org.esa.s1tbx.insar.gpf.InterferogramOp.initialize(InterferogramOp.java:195)
at org.esa.snap.core.gpf.internal.OperatorContext.initializeOperator(OperatorContext.java:485)
at org.esa.snap.core.gpf.internal.OperatorContext.getTargetProduct(OperatorContext.java:272)
at org.esa.snap.core.gpf.Operator.getTargetProduct(Operator.java:382)
at org.esa.snap.core.gpf.GPF.createProductNS(GPF.java:315)
at org.esa.snap.core.gpf.GPF.createProduct(GPF.java:290)
at org.esa.snap.core.gpf.GPF.createProduct(GPF.java:269)
at org.esa.snap.graphbuilder.rcp.dialogs.SingleOperatorDialog.createTargetProduct(SingleOperatorDialog.java:172)
[catch] at org.esa.snap.graphbuilder.rcp.dialogs.SingleOperatorDialog.onApply(SingleOperatorDialog.java:288)
at org.esa.snap.ui.AbstractDialog.lambda$initUI$14(AbstractDialog.java:494)
at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Unknown Source)
at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
at java.awt.Component.processMouseEvent(Unknown Source)
at javax.swing.JComponent.processMouseEvent(Unknown Source)
at java.awt.Component.processEvent(Unknown Source)
at java.awt.Container.processEvent(Unknown Source)
at java.awt.Component.dispatchEventImpl(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Window.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
at java.awt.EventQueue.access$500(Unknown Source)
at java.awt.EventQueue$3.run(Unknown Source)
at java.awt.EventQueue$3.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
at java.awt.EventQueue$4.run(Unknown Source)
at java.awt.EventQueue$4.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:159)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)


#5

What are the input products? It’s likely something is unexpectedly missing in the input products if they are not SLC SAR products or if they are just a tif file without orbit information etc. In any case the operator should be more robust to tell us what went wrong. With your input we can fix this.


#6

Hello everyone,
i am processing two sliced assembly s1-b dim products and i am getting an operation exception error (org.esa.snap.core.gpf.OperatorException: Interferogram: org.jblas.NativeBlas.dgemm(CCIIID[DII[DIID[DII)V)
during the interferogram formation step, although coregistration looks fine.
Any clue about what i am doing wrong?
Thank you in advance


#7

Hi @elenaath
Were you able to point out the reason for this error? We are processing a number of interferograms but getting this error for one pair.


#8

Hi,

I had the same error on a fresh Ubuntu 16.04 installation when trying to form an interferogram with the most recent version of SNAP (5.0.4).
(org.esa.snap.core.gpf.OperatorException: Interferogram: org.jblas.NativeBlas.dgemm(CCIIID[DII[DIID[DII)V)

It turned out that a library was missing. After installing the packet “libgfortran3” Interferogram formation runs fine.

@developers: Could you include checking for this dependency in the installer script?

Thanks,

Lukas


Error in SAR image corregistration: Error: [Nodeld: CreateStack] org.jblas.NativeBlas.dgemm(CCIIID[DII[DIID[DII)V)
#9

Thanks, that is the solution!


#10

Same problem, same solution. Lubuntu 17.10 x64


#11

I use Ubunto and I have same error on Back-geocoding of 29 S1. I don’t have any problem in Win 10 but in not in ubuntu. error: org.jblas.nativeblas.degmm…
should I remove Ubuntu and install Lubuntu?


#12

Dear @hamidbanan,

please have a look if this is a possible solution, it might be related to your error I guess.


#13

Dear @thho
thanks for your guide, I will check it.


#14

Thanks! I had a similar error with “Coregistration” and running sudo apt-get install libgfortran3 in my Ubuntu 18 LTS solved the problem.