Error of subsetting in Graph Builder

Hello everyone,

I am trying the subset an area from Sentinel 1 GRD zip file to execute Offset_Tracking using the following graph builder and WKT coordinates. Study region looks correct in the preview (the little map they provide with a box), but the output always deviates from the correct area. If I do the same steps using GUI, the output is aligning correctly. If anyone has any advice, I would greatly appreciate it!

Thank you

some shifts occur because the subset is applied to the data in range geometry (not geocoded). If you want to subset exactly the area defined by the WKT you have to terrain correct first. But this involves resampling of the data which potentially affects your offset tracking.

Is it an option to shift the WKT geometry towards East?

Thanks, ABraun. After I shift WKT towards East, I find that the selected area by the WKT is right in the output, but the coordinate is wrong. Although their coordinate system is WGS84, there are some offsets between the output and shp like the picture I upload.

at which step did you import the shapefile?

Open the output result in SNAP, then import the shapefile.

@ABraun Could this be similar to the issue I was seeing?

Seems like @qinghuise has the same issue where the SNAP Subset produces the correct output if used manually with each step whereas GPT doesn’t

For visibility @qinghuise I posted this recently: Graph Builder Subset and Terrain Correction Error Sentinel 1

So this is a bug? :rofl:

I believe so, at least it has been raised as a bug for my situation

So how did you solve it? Don’t you use the subset of graph builder?

For now no. Subsetting was only a performance benefit in my case.

We’re just living with the extra time it takes to process the imagery at the moment

I think so, yes. Although I am still wondering where this error comes from because subseting from GPT has been working fine for years.
Let’s hope the issue will be tackled soon.

I tried to repoduce this error and created a graph S1.xml (5.2 KB)

The WKT:
POLYGON ((42.19102478027344 2.404221534729004, 42.36405944824219 2.404221534729004, 42.36405944824219 2.2450509071350098, 42.19102478027344 2.2450509071350098, 42.19102478027344 2.404221534729004, 42.19102478027344 2.404221534729004))

This is the extent from the WKT

This is what SNAP produced

It took 66 seconds for three GRD input products in the batch mode, so it was surprisingly fast with the subset operator at the end.

I cannot observe any shifts. Maybe you can check in what points your approaches differ from mine, because I don’t see a difference at the moment.

I tried to follow your flowchart. The output is indeed correct.

But the offset I’m talking about is between the output and shapefile. After importing the shapefile, you can see an obvious shift.
However, if the subset is removed, the output and shapefile are perfectly matched. This also proves that the shapefile itself is no problem. So I think there is something wrong with the subset in graph builder.

very strange…
I added your topic to the issue, I also think the origin of the error might be the same as of @CiaranEvans’ problem.

Yes that’s what I get too, the data subset is correct, but it’s incorrect spatially.

Thank you very much for your prompt reply. We also look forward to solving the problem as soon as possible. :rofl:

my question is, why is the subset in my case located at the correct place while in your cases there is some shift introduced?
Maybe the subset operator called from GPT somehow messes up the tie-point-grids. @lveci is this possible?