Error: Operator Exeption - Message Missing band at 560.0 nm

Ok, thanks, I’ll try

But, if I run the correction in qgis, I can load that output images in sentinel ?

If it is the normal sen2cor output, then yes.

but, to open the images in snap, i have to open by the MTD , no? After I run the correction, how it will opened in snap?

Hello, sir. I can use your method on L1C but not on L2A after atmospheric correction. Will appear Missing band at 560.0 nm. (S2A_MSIL2A_20180820T051651_N0206_R062_T44TPM_20180820T082325.SAFE)

I hope you can help me, or if using L1C has any effect on the results.Please

This happens when you select any other output format than BEAM DIMAP, the metadata gets lost. If you open the image, there should be the bandwidths and wavelengths in each raster’s properties.

Hello, my output format is BEAM DIMAP ,But there was still this problem on the L2A in 2018. When I opened the resampled file, I found that the band B2-B4 was missing.

Hello, my output format is BEAM DIMAP ,But there was still this problem on the L2A in 2018. When I opened the resampled file, I found that the band B2-B4 was missing.
I tried L1C, resampling, and there was no lack of bandwidth.
So I tried to do atmospheric correction again, and the result seemed to be OK.
This problem occurred once in May, August and October in the 2018 images, and was normal in other months. Can you explain it?

if you perform atmospheric correction, make sure you include all resolutions as described here:

That means, you have to perform it for 10, 20 and 60, so that all bands are written in the target product.

Thank you. I corrected it at all resolutions(10m,20m,60m). I feel that there may be some bugs in atmospheric correction.

Hi everyone,
Thanks for helping me, I managed to run the LAI in the end…
but, anyone knows any article about LAI performed by SNAP?

Here is an example of articles concerning LAI

Validation of Sentinel-2 LAI and FAPAR products derived from SNAP toolbox over the Barrax cropland site (Spain)


l have same problem. as l see this data get from Copernicus Open Access Hub.
How is about data download from Land Viewer EOS. that does not give MTD data.
It is provide S2A_tile_20160613_39TTE_0_Product_metadata.xml and this does not opened by SNAP.
what can do in this case?

SNAP needs the S2 data in its original form, e.g. downloaded from the Copernicus Hub, PEPS or other sources which provide the initial product.
The EOS Land Viewer does not offer that (according to my knowledge and the documentation).

1 Like

thanks for reply.

But MTD data is not opened by SNAP. what may be reason for this result?

the MTD must be inside the original product folder, e.g.

which also contains the folders AUX_DATA, DATASTRIP, GRANULE, ect…

it is inside zip and copy to another folder for upload SNAP.

this is not a L1C Sentinel-2 product. It should look like this if you want to work with it in SNAP:


1 Like


I met the similar problem when I computed the fAPAR by the biophysical processor. It works well with L1C data. However, when I use the L2A images (.TIF) download from the Google earth engine, it always ends up with the error “Missing band at 560 nm”. But I checked the image and it has band at 560 nm. So do you know what s wrong here? Does biophysical processor only work on 1LC images?


I don’t know the GEE data, but if it is tiff the wavelength is probably not specified. Because GeoTiff has no format specification for doing it.
In general the processor should also work on L2A data. But it is best if you get the data from the official ESA sources.

You could add the wavelength information manually to your data.
Right click on the band and select properties. There you will see a field where you can enter the wavelength. Do it for all spectral bands.

ok. I ll try. Thank you so much.