Error: Operator Exeption - Message Missing band at 560.0 nm


#21

hi, I re-installed the SNAP and re-extracted the bands from the original zipfile of SENTINEL.

I run one biophysical model for LAI but the pixels are now bigger then 10m of resolition, they have about 65m each pixel, it is normal for SNAP or did I anythink wrong?


#22

Hi,
before running the biophysical processor it is required to resample the product. The final resolution of your LAI depends on the resampling parameters you have selected.


#23

Hi, To run the biophysical model I have to use the original extention of SNAP, but there is a way to cut my area from the image?


#24

I’m trying to run the biophysical after a resambling with 10m and the program say that is too big to run the biophysical


#25

Hi, I managed to do …
Now I have the LAI index for my region, but what means the number of eath pixel? There is a user manual to understand the result of SNAP outputs?


#26

The operator is described in the help (Help / Help Contents)


For specific the meaning of the LAI values, please see: Wikipedia


#27

You can find also the ATBD here: http://step.esa.int/docs/extra/ATBD_S2ToolBox_L2B_V1.1.pdf


#28

Hi, i’m getting problems to download the updates

its apearing:

The server may be unavailable at the moment. Try again later.

and

Not all of the plugins have been successfully downloaded. The server may be unavailable at the moment. Try again later.

I have tryed turn off my antvirus but still the same


#29

So maybe the server takes a nap again.
Also, other users experienced problems.

@oana_hogoiu, can you have look?


#30

ok,

and about the sent2cor I can not use… its appearing in the external tools :
Tool executable not found

but I did the “L2A_Process.bat --help” process and it seems to be ok

C:\Users\bfles_000>C:\Users\bfles_000\Downloads\Sen2Cor-02.05.05-win64\Sen2Cor-02.05.05-win64
‘C:\Users\bfles_000\Downloads\Sen2Cor-02.05.05-win64\Sen2Cor-02.05.05-win64’ não é reconhecido como um comando interno
ou externo, um programa operável ou um arquivo em lotes.

C:\Users\bfles_000>C:\Users\bfles_000\Downloads\Sen2Cor-02.05.05-win64\Sen2Cor-02.05.05-win64\L2A_Process.bat --help
usage: L2A_Process.py [-h] [–resolution {10,20,60}] [–sc_only] [–cr_only]
[–refresh] [–GIP_L2A GIP_L2A]
[–GIP_L2A_SC GIP_L2A_SC] [–GIP_L2A_AC GIP_L2A_AC]
[–GIP_L2A_PB GIP_L2A_PB]
directory

Sentinel-2 Level 2A Processor (Sen2Cor). Version: 2.5.5, created: 2018.03.19,
supporting Level-1C product version <= 14.5.

positional arguments:
directory Directory where the Level-1C input files are located

optional arguments:
-h, --help show this help message and exit
–resolution {10,20,60}
Target resolution, can be 10, 20 or 60m. If omitted,
all resolutions will be processed
–sc_only Performs only the scene classification at 60 or 20m
resolution
–cr_only Performs only the creation of the L2A product tree, no
processing
–refresh Performs a refresh of the persistent configuration
before start
–GIP_L2A GIP_L2A Select the user GIPP
–GIP_L2A_SC GIP_L2A_SC
Select the scene classification GIPP
–GIP_L2A_AC GIP_L2A_AC
Select the atmospheric correction GIPP
–GIP_L2A_PB GIP_L2A_PB
Select the processing baseline GIPP

C:\Users\bfles_000>


#31

Please have a look at the following posts:


and

If this doesn’t help please ask your question regarding sen2cor in the sen2cor category.
There are the experts.

But “Tool executable not found” sounds like you need to configure the path to sen2cor in “Tools / manage External Tools


#32

Ok, thanks, I’ll try

But, if I run the correction in qgis, I can load that output images in sentinel ?


#33

If it is the normal sen2cor output, then yes.


#34

but, to open the images in snap, i have to open by the MTD , no? After I run the correction, how it will opened in snap?


#36

Hello, sir. I can use your method on L1C but not on L2A after atmospheric correction. Will appear Missing band at 560.0 nm. (S2A_MSIL2A_20180820T051651_N0206_R062_T44TPM_20180820T082325.SAFE)

I hope you can help me, or if using L1C has any effect on the results.Please


#37

This happens when you select any other output format than BEAM DIMAP, the metadata gets lost. If you open the image, there should be the bandwidths and wavelengths in each raster’s properties.


#38

Hello, my output format is BEAM DIMAP ,But there was still this problem on the L2A in 2018. When I opened the resampled file, I found that the band B2-B4 was missing.


#39

Hello, my output format is BEAM DIMAP ,But there was still this problem on the L2A in 2018. When I opened the resampled file, I found that the band B2-B4 was missing.
I tried L1C, resampling, and there was no lack of bandwidth.
So I tried to do atmospheric correction again, and the result seemed to be OK.
This problem occurred once in May, August and October in the 2018 images, and was normal in other months. Can you explain it?

S2B_MSIL2A_20181024T051859_N0206_R062_T44TPL_20181024T090955_s2resampled.data


#40

if you perform atmospheric correction, make sure you include all resolutions as described here:

That means, you have to perform it for 10, 20 and 60, so that all bands are written in the target product.


#41

Thank you. I corrected it at all resolutions(10m,20m,60m). I feel that there may be some bugs in atmospheric correction.