Error while running SNAP command line

Below is the message displayed. Is it processed properly or do I need to run it again?
Why this is displayed “INFO: org.hsqldb.persist.Logger: Database closed”

gpt E:\PHD\Thesis\SARSoft\ALOS\Pair1_Pre-Pro_Cal.xml
INFO: org.esa.snap.python.gpf.PyOperatorSpi: Python operator ‘S2RutOp’ registered (Python module: ‘s2_rut’, class: ‘S2RutOp’, root: ‘C:\Users\SAIPLANNER\AppData\Roaming\SNAP\modules\org-esa-snap-snap-rut.jar’)
INFO: org.esa.snap.core.gpf.operators.tooladapter.ToolAdapterIO: Initializing external tool adapters
Executing processing graph
INFO: org.hsqldb.persist.Logger: dataFileCache open start
…10%…20%…30%…40%…50%…60%…70%…80%…INFO: org.hsqldb.persist.Logger: Database closed
…90% done.

These are logging messages from a library which is used. You can ignore them.
It’s not an error. It is sometimes hard to disable such loggings from third party libraries.
Your processing has finished properly.


Thanks marpet.

A post was split to a new topic: Different results for VH and VV

Is it possible to disable this info message? I tried the Python’s available ignore functions but none of them worked. I’m currently automating this process and the program always stops at this point so my process stuck here every time.

It is unlikely that an INFO message cause your process to become stuck. Such messages are generated in Java code. Using Python won’t affect Java processing, but could hide important clues to the reason for your process becoming stuck.

Which info message are you referring to?
If you see the ‘done’ then this processing has been completed and the process stops.
Depending on how you invoke the processing this might interfere with your Python script.
Have you tried maybe this is something you want to try.
Introducing snapista, a GPT wrapper for Python - Show Room - STEP Forum (

How logging can be disabled is explained here:


I am running code to resample and subset a number of S2 images. It has been working well over the past day, however, i am now receiving a message saying “INFO: org.hsqldb.persist.Logger: Database closed” after the resampling process and the subset is not being performed. The process was working fine up to this point, does anyone know what this message means or how to overcome the problem?


The message “INFO: org.hsqldb.persist.Logger: Database closed” is not harmful.
If the process got stuck there must be another reason.
Can you describe your setup in more detail?
Creating a new thread for the discussion would be good.