Extra fine RadarSat-2 image (XF0W2)

I am trying to open an Extra Fine Radarsat-2 image (XF0W2) in the gui. However, the image viewer gives me the following error:


The same error is reported when trying to apply coregistration or terrain correction on the image. The Sentinel toolbox version I am using is 2.07. I am able to open the image in S1TBX version 1.1.2, however. What can be causing this error?

I don’t seem to get this with any RS2 product I have.

Thank you for your reply. Hmm, that is strange. It might be local problem then.

I do not get the problem when I am using a RadarSat-2 standard (S3) product either. Specifically the XF0W2 (extended fine or extra fine: 5 m resolution, 125 km swath width) product is causing errors. What kind of RadarSat-2 images are you using?

I am getting a different error when trying to open many (but not all) RS2 images. This is using SNAP 2.0-beta-08 on windows 7.

The error I get is:

[input=C:\some folder with RS2 image\product.xml]:
seekForwardOnly and allowSearch can't both be true!

Images I have tried and for which the error is thrown are of the following modes: SCNB, SCWB, XF0W2.
I have tried some of these images on S1TBX 1.1.1 and they are loaded fine.

Images I have tried and that SNAP opens OK are of the following modes: W2, MF3W.

I have looked some more into the issue. After having converted the XF0W2 zipped product to a “beam-dimap” file in S1TBX version 1.1.2, I was able to open this “dim” file with the image viewer in the gui of S1TBX 2.07. Hence, the problem must have something to do with the productreader of the newer S1TBX version.

I have tried to convert the product in S1TBX 2.07 to “dim”, but this was not completely successful. It only converted part of the product and aborted with the same error as mentioned before.

CSS the issue with the seekForwardOnly has been fixed.
Cwmverhoeven, the XF0W2 problem may be something else. Is there a product available where this occurs?

Iveci, is there any way I can install this fix? Then I can try XF0W2 again.

The XF0W2 problem is due to its size. This problem would also show up with S-1 and TSX. I’ve updated the readers to to use the fileCache for very large images.