Failed bundle installation

Hi! I am creating a new plugin for SNAP and I have the following issue.
I am trying to deliver a conda environment together with my plugin. My conda environment is hosted and I use the URL for installing the bundle. The issue is that the bundle installation is failing every time and in the SNAP logs I can see the following message.
INFO []: Timeout when waiting for DNS response. ([my_host]) where my_host is the DNS of the host I use each time. I tried different for hosting my files like owncube or azure blobs but I get the same error every time. The error looks exactly the same with the one reported here. In the above link they suggested some steps to overpass this error, but none worked for my case.
Any idea on how can I solve this issue?

Just an update on this issue. Instead of using bundleType ZIP, I used INSTALLER and I converted my directory to a self-extracting script using makeself. This way my conda environment is extracted using the bundle installer. The DNS timeout warning is still there. The bundle installation succeeded one time, and failed two times when I was testing it, but all of the times the folder was extracted successfully.

What you are doing sounds interesting, but I wonder if this will ever work. Or I haven’t fully understood yet what you are doing.
Actually, it is not possible to provide your own conda env for your Python plugin. There is only one which is used by snappy. Actually we have it on the roadmap that conda environments can be defined by plugins.
However, maybe you can tell a bit mor about what you are doing. Maybe you found some interesting solution. Is your project open source?

Initially we were trying to build python processors for our plugin, but we had quite a few issues, and then we decided to create our standalone tool adapter. The way it works, is that we provide a conda environment together with some python scripts, and after successfully installing the bundle (conda environment) we run our python scripts using the provided conda environment. This works pretty well so far, and in my opinion much better than our previous version of python processors.
Our project is open-source and can be found here

The problems which we experienced with the Python processor are summarized in the following forum thread:

We are still struggling with installing the STA plugin as described in Writing Python plugin. @marpet, would you have any hints on what could be wrong?