Georeferencing problem with Pleiades data

I’m having a problem to import a Pleiades in SNAP. I tried the standard procedure File->import->Optical Sensors->Pleiades and I select the original zip file but appears an error window with the message “No appropriate product reader found”. I’ve the last version of SNAP and in the other programs i can open it correctly.
Can someone help me?

Your Pleiades data is in TIF format ?

Yes, I have the Multispectral and the Panchromatic product in TIFF format, but I want to import the complete zip file. Is that possible or should I import in SNAP the two product separately as a tiff file?

Personally, I import the data tif … and it works fine

1 Like

Hello everyone!
I import my plèiades data in tiff format and I create a NDWI mask but the water bodies are displaced. Is there someone who knows how to georeference them correctly?

How was the mask created?


I’ve moved this discussion into a new thread. The topic is more appropriate.

If you know the coordinates of placemarks in your data, you can set GCPs and create a new GeoCoding based on locations.
See this post:

But maybe this is not the problem.
The images you have posted shows the mask and as background the RGB of the Pleiades data.
So, this shouldn’t be shifted.

I agree with ABraun’s question, how did you do the mask and the overlay?

To open the product as a complete product it should be enough to select the VOL_PHR.XML file.

@oana_hogoiu can you check this too? Maybe you have an explanation for this.

Thanks for all the answers.
I tried to import the complete product to select VOL_PHR.XML file but appears the same error window “no appropriate product reader found”.
I calculated the NDWI from only multispectral product with the expression (B2-B4)/(B2+B4) and I created the mask with the expression “if NDWI>0 then 1 else 0”.
The image I posted shows the mask imported in QGIS, but I have already checked if it is in the same reference system and I tried to import the original tiff file in QGIS and it’s shifted as well.

I also wanted to exploit the Pleiades data from ESA, but I ended up with some distortion. Actually in the bundle of the .zip file I found a KMZ preview version, which over imposed in GE looks fine. But when I tried to open the JP2 file with bands in QGIS it didn’t look good. Same problem with test in SNAP7.0 - got the same error as in the original post.
I’m wondering if the Pleiades reader can handle this sensor?

Thank you

Can you upload your product here: so that we can take a look?
Thank you in advance.

could you check mine as well?

Of course, you can upload it in the same location.
Thank you in advance.

@oana_hogoiu I uploaded my file. could you please check if you have it.

Thank you for the sample product.
We noticed that your Pleiades product contain 4 PMS bands (pan-sharpened).
The actual reader from SNAP is able to read products containing 1 panchromatic band (PS) + 4 multi-spectral bands (MS).
It can be updated in order to be able to read also products with 4 PMS bands.

@Ilaria765 can you specify the type of your product? (that you weren’t able to open in SNAP using VOL_PHR.XML)
Thank you in advance.

@oana_hogoiu Thank you for your reply.

How to to this? I downloaded the data from ESA TMP site. I used QGIS with the same result. Also I QGIS noticed that the raster is rotated -90 degrees.

I meant the reader can be updated. I created a ticket for this in our issue tracker:

@oana_hogoiu Thank you for creating ticket.
I also would like to kindly to ask you to check the other issue - the rotation to -90 degrees.
Thank you.

The issue with the rotation (and also geolocation) when opening the JP2 file comes from its GML metadata.
For WGS 84 (EPSG:4326) the axis are expected to be north/east instead of east/north ((y, x) instead of (x, y)).
Currently the JP2 reader don’t treat the special case of EPSG:4326. Usually the coordinates are (x, y), not the other way.
I have also created a separate ticket for this in our issue tracker: