Graph Builder overwrites file when using BiophysicalOp

I have been creating a Graph to process S2 images as follows: subset>resample>biophysicalOp, but I cannot get a filename such as “productName_biophysicalOp”, as the default setting in the “Write” node is “BiophysicalOp”. Thus, when applying this graph with a batch, SNAP keeps overwriting the files.
This issue is solved when removing the “BiophysicalOp” node, however. Any idea of what can cause this bug?
Attached is the xml file of the graph inversion_LAI_4.xml (3.5 KB)


Hi Julien,

have you seen this post already?

But, I fear that I can’t be much a help hear, I’m not using these components much.
Maybe @lveci, @oana_hogoiu or @ABraun can help.

As an alternative you can do batch processing from the command line.
There is a little tutorial available:

Hi Marco,
I did see this thread, and tried the suggested solution (although I am working with zip files), but it did not work either.
I will try to use the batch process from the line command, thanks for the suggestion and link!

Hello @jumo

I have seen the xml of yours, maybe you can try to remove the “file” element of write node in you graph xml file and try again.

Hi @constantinevi
Thanks for the suggestion, I removed the file information as follows (I did not know how to insert snippets of code so I just deleted the first “<” of each line), but I still get one identical name for output files (i.e., BiophysicalOp).

! node id=“Write”>
! operator>Write
! sources>
! sourceProduct refid=“BiophysicalOp”/>
! /sources>
! parameters class=“com.bc.ceres.binding.dom.XppDomElement”>
! file>
! formatName>GeoTIFF
! /parameters>
! /node>