Graph builder - subset

i am still failing to get a subset via graph builder.
i saw few older posts but i don’t seem to be able to follow their apparent success and workarounds.

firstly, i have inputted a shp file (originally its in a epsg of 2039 but i converted it to latlon ). it opens and shows ok on screen.
i got the WKT from qgis and inputted it in the right space in the subset node (getting the wkt from snap worked fine but coordinated were in the 2039 epsg).
once run, i get the “processing completed in 3 seconds” but nothing happens (i tried several times, different epsg and other subsetting options and… failed miserably…
(i looked at How to subset an image in the graph builder? and other links - with no joy)
i am using version latest version of snap on unix (ubuntu 18:04) ad trying to clip a sentinel2 s2 product which i successfully re-sampled to 10m. i also may add that other processes also seemed to work (classification) but it all goes painfully slow and snap freezes on me a lot…
my ultimate aim is to batch process a bunch of images and re-sample-subset-clculate some indices
a bug or have i been really dumb and missed out something here???
any solutions?

1 Like

I think it is not possible to make a subset using a shape file right now on SNAP. The “polygon” in the subset processor refers usually to a five coordinate polygon (square, rectangle) with the final point being the same as the first one.

Hi, If the product contains a large area, it is possible to create a subset before resampling the product?