How Decompose Sentinel-1 GRDH data

Hello, everyone. How can I Decompose Sentinel-1 GRDH data? which pre-processing should I do?

Polarimetric decomposition can only be done with the SLC products.
http://sentinel1.s3.amazonaws.com/docs/S1TBX%20Polarimetry%20Tutorial.pdf

most of the decompositions require 4 polarizations: HH, HV, VH and VV.

However, most of the Sentinel-1 data in IW mode is in only one or two polarizations:

There are studies which apply decompositions on dual polarized SAR data:

You can chose the Entropy-Alpha Dual Pol Decomposition for a try.

It is discussed in other topics if it makes sense:

3 Likes

Thank you ABraun for your reply. I want to extract Forestry area from my study area. Can I use GRDH data or I have to use SLC one? If I can use GRDH data, please tell me how can I do.

for the estimation of forest areas GRD data is completely sufficient.
The general work flow is:

  1. Apply Orbit File
  2. Calibrate
  3. Speckle Filter
  4. Range-Doppler Terrain Correction

You can use the ratio between VV and VH in order to extract the forest areas.
VH values are high where ever the incoming vertical wave is backscattered horizontally to a high degree. This is often the case for vegetation with larger volumes.

Make A RGB composite out of Red: VV Green: VH and Blue: VH/VV. The Forest ares should be clearly visible then.

5 Likes

Thank you for your reply but ABraun when I did " Apply Orbit File", the below error appeared. I would be glad if you can help me

.

Are you using the latest updates S1TXB 4.0.4? This shouldn’t happen. If it’s not found in the snap archive it should find it on the qc website. If you are using 4.0.4 and still getting this, what is the product file name?
Thanks

lveci thank you for your answer .
SNAP version that I use is 2.0.1.0.
Which site can I download version 4…0.4?

lveci I checked the qc website. Which data should I download? in additional, the name of data that I am using is “S1A_IW_GRDH_1SDV_20160704T143552_20160704T143617_012000_012854_BB20.SAFE”

you can download the lastest official version of SNAP here:
http://step.esa.int/main/download/

Afterwards (if not done automatically) select Help > Check for updates.

Thank you for your attention ABraun

Is that true that I can’t apply the filter in images with sigma naught values?

If it is, should I calibrate my image GRDH with all the boxes unmarked? Or I shouldn’t calibrate it at all?

thanks!

Speckle filters were designed for the original acquired data, meaning that they operate best on images in Slant Geometry (S1 SLC data).
They however still work on GRD data as well. If you directly download GRD data I would first calibrate to Sigma0 and then speckle filter the image. As Sigma0 is the standard output you don’t need to check Beta0 or Gamma0 additionally. The complex output calibrateion is only needed for polarimetric analyses which work with the scattering matrix of the complex image so you won’t need that either.

I can’t think of a reson why speckle filers may not be applied on calibrated data.

1 Like

Thank you very much!

I will let you know of the final result! It is taking a life time to run it but I think it will work. I understood better now about the speckle filter. :wink: Thanks!

Hello ABraun. i did your mentioned processsing and made RGB colour. it was good but when i want extrac data in format of Google Earth(KMZ), this error appears.

Could you help me, please?

hmm, that message isn’t very helpful :slight_smile:

Is the data projected into WGS84?
How large is your raster?
Did you also try exporting it as a png to see if it works?

I’m a fresh new user of SNAP. my question could be silly but how can I know that data has been projected into WGS84?

If you performed the Range Doppler Terrain Correction at the end of your preprocessing you can select a coordinate system. WGS84 is based on longitudes and latitudes in degree and preset in the module. Google Earth needs this projection for a proper display of the data.
Usually, when your data is not projected you can’t choose “export to kmz” and get an error message “data should be projected to WGS84”. However your error is different.
When does it occur?
Does the export start at all?

Hello laismoreira,

Don’t run Speckle Filter processor from the “Radar -> polarimetric -> polarimetric speckle filter” menu. But try to run it from the “Radar -> Speckle speckle filtering” menu. It might work!

Piero

Hi Braun,

I do not have the Polarimetric option in the S1TBX Radar drop down menu. Am I missing a plug-in? I have checked to ensure my system is up to date, as well.

have a look under Tools > Plugins if the The Radarsat-2 Toolbox extension is installed and active.