Iceland Aster DEM Coregistration Auxdata


I am trying to use Aster 1sec GDEM tiles that I downloaded from NASA’s Earthdata Website for Sentinel-1 TOPS Coregistration of SLC IW images acquired over Iceland. I am using OS X El Capitan 10.11.5.

I placed the tiles in zip-format in the AuxData/DEMs/ASTER folder and checked that the file points to that location. Unfortunately, the S1Tbx cannot find/use the downloaded tiles and keeps producing empty slave and master images as output. Does anyone have an idea what could be cause of this?

Just to check, I ran the coregistration using the GETASSE30 auto-downloaded DEM and the output looked fine then.

I would be very grateful for any advice or recommendations on how I can solve this issue!



Hi Christine,

I have no experience with ASTER so far, but in my installation the folder name is a bit different:
auxdata\dem\ASTER 1sec GDEM

Did you use this or just auxdata\dem\ASTER?


Thank you for the prompt advice! I actually had to add an ‘ASTER’ folder in AuxData/DEMs manually (only folder in there was the SRTM_DEM/tiff), and have also just added a ‘ASTER 1sec GDEM’ and a path for that in the file, but unfortunately that has not solved the issue.

Could the format of the ASTER tiles be the problem? I kept them in .zip archives together with the corresponding .zip.xml files…

I looked at the error log, but I am not sure what it means, maybe someone understands this better:

java.lang.UnsatisfiedLinkError: no jhdf5 in java.library.path
at java.lang.ClassLoader.loadLibrary(
at java.lang.Runtime.loadLibrary0(
at java.lang.System.loadLibrary(
at ncsa.hdf.hdf5lib.H5.loadH5Lib(
at ncsa.hdf.hdf5lib.H5.(
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(
at org.esa.snap.dataio.hdf5.Hdf5ProductWriterPlugIn.loadHdf5Lib(
at org.esa.snap.dataio.hdf5.Hdf5ProductWriterPlugIn.(
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(
at java.lang.reflect.Constructor.newInstance(
at java.lang.Class.newInstance(
at java.util.ServiceLoader$LazyIterator.nextService(
at java.util.ServiceLoader$
at java.util.ServiceLoader$
at org.esa.snap.SnapCoreActivator.loadServices(
at org.esa.snap.core.dataio.ProductIOPlugInManager.(
at org.esa.snap.core.dataio.ProductIOPlugInManager$Holder.(
at org.esa.snap.core.dataio.ProductIOPlugInManager.getInstance(
at org.esa.snap.core.gpf.ui.TargetProductSelectorModel.(
at org.esa.snap.core.gpf.ui.SingleTargetProductDialog.(
at org.esa.snap.core.gpf.ui.DefaultSingleTargetProductDialog.(
at javax.swing.AbstractButton.fireActionPerformed(
at javax.swing.AbstractButton$Handler.actionPerformed(
at javax.swing.DefaultButtonModel.fireActionPerformed(
at javax.swing.DefaultButtonModel.setPressed(
at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(
at java.awt.Component.processMouseEvent(
at javax.swing.JComponent.processMouseEvent(
at java.awt.Component.processEvent(
at java.awt.Container.processEvent(
at java.awt.Component.dispatchEventImpl(
at java.awt.Container.dispatchEventImpl(
at java.awt.Component.dispatchEvent(
at java.awt.LightweightDispatcher.retargetMouseEvent(
at java.awt.LightweightDispatcher.processMouseEvent(
at java.awt.LightweightDispatcher.dispatchEvent(
at java.awt.Container.dispatchEventImpl(
at java.awt.Window.dispatchEventImpl(
at java.awt.Component.dispatchEvent(
at java.awt.EventQueue.dispatchEventImpl(
at java.awt.EventQueue.access$500(
at java.awt.EventQueue$
at java.awt.EventQueue$
at Method)
at java.awt.EventQueue$
at java.awt.EventQueue$
at Method)
at java.awt.EventQueue.dispatchEvent(
at java.awt.EventDispatchThread.pumpOneEventForFilters(
at java.awt.EventDispatchThread.pumpEventsForFilter(
at java.awt.EventDispatchThread.pumpEventsForHierarchy(
at java.awt.EventDispatchThread.pumpEvents(
at java.awt.EventDispatchThread.pumpEvents(
org.esa.snap.core.gpf.OperatorException: Operator ‘GLCMOp’: Mandatory source product (field ‘sourceProduct’) not set.
at org.esa.snap.core.gpf.internal.OperatorContext.processSourceProductField(
at org.esa.snap.core.gpf.internal.OperatorContext.initSourceProductFields(
at org.esa.snap.core.gpf.internal.OperatorContext.initSourceProductFields(
at org.esa.snap.core.gpf.internal.OperatorContext.initializeOperator(
at org.esa.snap.core.gpf.internal.OperatorContext.getTargetProduct(
at org.esa.snap.core.gpf.Operator.getTargetProduct(
at org.esa.snap.core.gpf.GPF.createProductNS(
at org.esa.snap.core.gpf.GPF.createProduct(
at org.esa.snap.core.gpf.GPF.createProduct(
at org.esa.snap.core.gpf.ui.DefaultSingleTargetProductDialog.createTargetProduct(
at org.netbeans.modules.progress.ui.RunOffEDTImpl$
at org.openide.util.RequestProcessor$
at org.openide.util.RequestProcessor$

Any ideas or help are very welcome!

maybe it is the naming convention of the zip-files that prevents that the right data is found by SNAP. How is your data named?

It turned out to be two issues: somehow the zip file I downloaded from NASA did not actually contain all the tiles I needed and also I had to put them in a ‘hidden’ folder (OSX is a bit funny with that). But it is all solved now and works. Thank you for your time though!

I’m glad you solved it.

Maybe you can explain a bit more how you found out that all required tiles were not included and a bit about the hidden folder in OSX. Just in case there are people who have the same issue some day.

Tell me more about how you deleted the topographic phase