Installation problem in Linux

Hello,
I’m having some problems installing snap 6.0 in ubuntu (version 14.04.3).
I run the installer, the process starts and finishes, but the software doesn’t open after it. if I digit snap in the console, it says that the software hasn’t been installed. if I run sudo apt-get install snap it says that I have already the most recent version installed. I uninstalled snap and ran the installer again and the same happens.

In this computer, someone installed previously another software called also snap. I deleted everything related but probably there is still some conflict with previous installations. Also, there have been other versions of ESA SNAP installed before.

I’m neophyte in Linux, so, any help will be very welcome.

Thanks!
Laura

Hi Laura

Did you download the installer from the website and tried to run it?

Can you list your /opt/snap/ directory and see it anything is there?

ls /opt/snap/

Regards
Kenan

Hi Kenan,
yes, I downloaded the installer from http://step.esa.int/main/download/ and ran it.

I don’t have a snap folder into the opt directory

zoffoli-m@Tower-7810:/opt$ ls
cel google libreoffice5.2

best,
Laura

You cannot call SNAP Desktop just by typing snap in your terminal

Stupid question but did you tried just typing snap in your search bar? If it is installed, you have the 2 launchers below here

I know it’s not Ubuntu but kind of (Linux mint is based on Ubuntu)

In my case, SNAP is installed in /home/qg/snap and /home/qg/.snap (hidden directory). The laucher itself is located at /home/qg/snap/SNAP Desktop

Dear @mlzoffoli,

you ran into a problem caused by a conflict of the same name for two different software. The snap package, which was already installed, is a default installation which comes with your ubuntu distribution, find some information about it here https://en.wikipedia.org/wiki/Snappy_(package_manager) if you do

sudo apt-get install snap

you do not install esa’s SNAP but Canonical’s snaps, this software would not appear if you search for it. I extracted the software installation and configuration for esa’s SNAP from an other manual which I have written for some other workflows, find it here: SNAP_installation.html (1.0 MB)
. By following these steps closely, I think you will have esa’s SNAP installed and configured properly really quick. Good Luck

Hi again
Here is what I have done as the most simple installation:
Get the file by using:
wget http://step.esa.int/downloads/6.0/installers/esa-snap_sentinel_unix_6_0.sh
It took some time to download:
esa-snap_sentinel_unix_6_0.sh 100%[=================================================>] 516.60M 3.03MB/s in 3m 7s
Then make it executable:
chmod +x esa-snap_sentinel_unix_6_0.sh
Then install it:
sudo ./esa-snap_sentinel_unix_6_0.sh

After installation starts it asks some questions:
Unpacking JRE …
Preparing JRE …
Starting Installer …
This will install ESA SNAP on your computer.
OK [o, Enter], Cancel [c]

Delete SNAP's configuration data and user settings?
The installer detected SNAP user data directories from a previous
installation. These directories contain system file used by the application
and also stored graphs, RGB profiles or other auxiliary data. The data
stored in these directories might not be compatible with this new SNAP
version anymore.

Shall the installer try to remove these directories?
Yes, try deleting all SNAP user data [1], Delete only SNAP-internal configuration data (recommended). [2, Enter]

Where should ESA SNAP be installed?
[/usr/local/snap]

Which components should be installed?
*: SNAP [*1]
1: Sentinel-1 Toolbox [*2]
2: Sentinel-2 Toolbox [*3]
3: Sentinel-3 Toolbox [*4]
4: Radarsat-2 Toolbox [*5]
(To show the description of a component, please enter one of *1, *2, *3, *4, *5)
Please enter a comma-separated list of the selected values or [Enter] for the default selection:
[1,2,3,4]

Did you see all those steps when installing?

/Kenan

2 Likes

Thank you so much to everyone! I’ve been able to install it! now the problem is to install plugins. I got the following errors:
Networking problem in file:/home/zoffoli-m/Téléchargements/sen2coral-kit-1.0.0.nbm
Check your proxy settings or try again later. The server may be unavailable at the moment. You may also want to make sure that your firewall is not blocking network traffic. Your cache may be out of date. Please click Check for Updates to refresh content.

the same if I check for updates… any idea?

thanks again!
Laura

That is an error reported by NetBeans which is the platform that SNAP was built on.

My best guess is that the proxy settings are not set. They are often required if you work in large organization.

Go To: Tools -> Options -> WWW and check the proxy settings.
Sometimes the system settings are not enough and you have to fill them yourself.

/Kenan

thanks a lot, Kenan. I’ll try that

best,
Laura

Hello dear @KenanV , @thho and @marpet, and other users

I am using SNAP during long time but after installing ubuntu18 instead of ubuntu16, ı need to install snap6 again and ı have this installation problem first time

while getting the setup from internet ı need the code wget and then ı write chmod +x esa-snap_sentinel_unix_6_0.sh and then sudo ./esa-snap_sentinel_unix_6_0.sh but ı had some problems on installation like shown below terminal pictures

first my installation wasn’t completed completelly (stop on %99) and later ı had the problem like 2. picture

snap-accessuserdirectoryhatas%C4%B1

How can ı fix this problem ? Can you help me please ?

Thank you so much

I never had that error, but have you tried installing the module:

sudo apt install libcanberra-gtk-module libcanberra-gtk3-module

Otherwise i would suggest to install it as a user and not using sudo. At least for me it made life easier :slight_smile:

As @KenanV suggests, installing without sudo is better. See

Regarding the missing library. I haven’t seen this problem before. Maybe it seems Ubuntu changed something between the versions.

We will check this. Thanks for the report.

ı have already installed it without sudo before but now ı understood what the problem is,

I think, the problem caused by ubuntu18. Because when ı reinstall ubuntu16 again now, ı don’t have any problem about installing snap or opening snap

1 Like

Hi All,
snap_error

Later I modified the file permissions in .snap/system after which I was able to start SNAP but with an error as shown below

I tried everything in the thread except the same in ubuntu 16. Any thoughts would be helpful. Thanks!

This seems to happen only in some situations. So it is probably specific to the system. So far we haven’t found out was this causes.
Maybe someone else can help us out?

Hello Everyone,
I had a similar issue after installing SNAP 7.0 (downloaded on 2019/Nov/19) using the above procedure described by KenanV.
The messages when starting snap in the terminal was:
"Gtk-Message: 13:17:49.557:Failed to load module “canberra-gtk-module”

But after installing the module with:
sudo apt install libcanberra-gtk-module libcanberra-gtk3-module

And starting snap again, it all worked fine.

I use Ubuntu 18.04.2. (Linux 5.0.0-32-generic with x86_64 GNU/Linux OS)

1 Like