Issue with subset in SNAP 7

Dear all,

a problem has been reported with the subset operator.
I opened this thread to raise awareness for it. Maybe your processing chains are affected by the issue.
In brief, the tie-point grids are not correctly subsetted. If your data contains tie-point grids, like OLCI or SLSTR, subsequent processing steps might go wrong.

For details see here:

We are working on it and hope to provide an update soon.

Sorry, for the inconvenience this might cause.

It turned out that only graphs created with the GraphBuilder are affected. It specifies the referenceBand parameter in the described use case, which leads to the error. If you save the graph to XML and use it with gpt the processing works if you remove the tag referenceBand.

1 Like

hi marpet
first - many thanks for addressing this - it has driven me crazy last week
i will be delighted to try your solution (i wanted a standard 10m resolution anyway so for me - its perfect…
can you direct me to a tutorial or show me somehow how its done - i can send you an xml file as an example - ill be very happy to try it and ill send images of how its done and how it worked out in this forum
have a good day and thanks in advance
tamir
snap_sentinel_set_cubic_clip_indices_exports_edited2.xml (18.3 KB)

I’m not sure if I fully understand your question. As you is S2 data you shouldn’t be affected by this issue. But you can remove the referenceBand tag from the subset node in the attached example.

Don’t expect me to answer soon again. I’m actually on holiday, but waiting at the doctor. Di maybe someone else can step in.

hi marpet
obviously - i am effected - i made the original complaint about the image shifting
in any case i dropped off the subset component and run my graph successfully (i later clipped using qgis+gdal batch )
i am going to look into the ref tag option. anyone who has done it is welcome to offer help

have a good holiday forget about me - even at the doctors…

hi everyone
just letting you all know - i have tried the above (removing the referenceband tag ) but shifting the resulting image as before.
the graph does - open>re-sample (10m)>subset>write…
the subset component is responsible for this - without it all is well…