"java.lang.NullPointerException" error while using gpt or graph builder for processing

This problem has become part of my processing :pensive: while doing processing it wont show any error but when i open the processed output image It always shows this error. I have seen all the discussion threads related to this, but non of them solved my problem. Kindly, check.
My graph file : myGraph.xml (5.5 KB)
Error :

at com.sun.media.jai.util.SunCachedTile.(SunCachedTile.java:80)
at com.sun.media.jai.util.SunTileCache.add(SunTileCache.java:257)
at javax.media.jai.OpImage.addTileToCache(OpImage.java:1087)
at javax.media.jai.OpImage.getTile(OpImage.java:1142)
at org.esa.snap.core.datamodel.StxFactory.accumulateTile(StxFactory.java:339)
at org.esa.snap.core.datamodel.StxFactory.accumulate(StxFactory.java:323)
at org.esa.snap.core.datamodel.StxFactory.accumulate(StxFactory.java:296)
at org.esa.snap.core.datamodel.StxFactory.create(StxFactory.java:200)
at org.esa.snap.core.datamodel.StxFactory.create(StxFactory.java:274)
at org.esa.snap.core.datamodel.RasterDataNode.computeStxImpl(RasterDataNode.java:2453)
at org.esa.snap.core.datamodel.Band.computeStxImpl(Band.java:504)
at org.esa.snap.core.datamodel.RasterDataNode.getStx(RasterDataNode.java:2420)
at org.esa.snap.core.datamodel.RasterDataNode.createDefaultImageInfo(RasterDataNode.java:1827)
at org.esa.snap.core.datamodel.Band.createDefaultImageInfo(Band.java:483)
at org.esa.snap.core.datamodel.RasterDataNode.getImageInfo(RasterDataNode.java:1809)
at org.esa.snap.core.datamodel.RasterDataNode.getImageInfo(RasterDataNode.java:1792)
at org.esa.snap.core.image.ImageManager.prepareImageInfos(ImageManager.java:834)
at org.esa.snap.core.image.ColoredBandImageMultiLevelSource.create(ColoredBandImageMultiLevelSource.java:51)
at org.esa.snap.core.image.ColoredBandImageMultiLevelSource.create(ColoredBandImageMultiLevelSource.java:47)
at org.esa.snap.core.image.ColoredBandImageMultiLevelSource.create(ColoredBandImageMultiLevelSource.java:41)
at org.esa.snap.ui.product.ProductSceneImage.(ProductSceneImage.java:69)
at org.esa.snap.rcp.actions.window.OpenImageViewAction.createProductSceneImage(OpenImageViewAction.java:271)
at org.esa.snap.rcp.actions.window.OpenImageViewAction.access$100(OpenImageViewAction.java:69)
at org.esa.snap.rcp.actions.window.OpenImageViewAction$1.doInBackground(OpenImageViewAction.java:236)
at org.esa.snap.rcp.actions.window.OpenImageViewAction$1.doInBackground(OpenImageViewAction.java:213)
at com.bc.ceres.swing.progress.ProgressMonitorSwingWorker.doInBackground(ProgressMonitorSwingWorker.java:55)
at javax.swing.SwingWorker$1.call(Unknown Source)
at java.util.concurrent.FutureTask.run(Unknown Source)
at javax.swing.SwingWorker.run(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
Caused: java.util.concurrent.ExecutionException
at java.util.concurrent.FutureTask.report(Unknown Source)
at java.util.concurrent.FutureTask.get(Unknown Source)
at javax.swing.SwingWorker.get(Unknown Source)
[catch] at org.esa.snap.rcp.actions.window.OpenImageViewAction$1.done(OpenImageViewAction.java:221)
at javax.swing.SwingWorker$5.run(Unknown Source)
at javax.swing.SwingWorker$DoSubmitAccumulativeRunnable.run(Unknown Source)
at sun.swing.AccumulativeRunnable.run(Unknown Source)
at javax.swing.SwingWorker$DoSubmitAccumulativeRunnable.actionPerformed(Unknown Source)
at javax.swing.Timer.fireActionPerformed(Unknown Source)
at javax.swing.Timer$DoPostEvent.run(Unknown Source)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
at java.awt.EventQueue.access$500(Unknown Source)
at java.awt.EventQueue$3.run(Unknown Source)
at java.awt.EventQueue$3.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:159)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

1 Like

I observed that when ever i include terrain correction it is causing this problem. why is it so ?

Do you think the source product read causes the problem and should be removed?

@falahfakhri I don’t think “Read” is causing the error.The problem is definitely in “terrain correction”. My graph file is working fine when I exclude the “terrain correction” from it other wise it is causing the problem whether I run it using gpt or using graph builder in the snap desktop with terrain correction included in it.

Did you get any error within the graph while adding the terrain correction? Or not?

Yes. I am getting the same error when I run it using graph builder also.

No , I meant did any error appear in GB panel?
Before executing the graph?

No. Error is coming when I open the image, which I got from the Graph builder(if terrain correction is included)

In terrain correction, what is the DEM , did you select?

It is the same DEM, selected alongside your processing?

“SRTM 3Sec”. It is the same DEM which I usually work with.

Might be this causes the problem, try up to use SRTM 1sec HGT, auto download,

As per your suggestion. I used SRTM 1sec HGT . But no use . Still the same problem .
@marpet @falahfakhri @ABraun

Sorry I’m out of idea, but here also more less similar to this issue, But in this is concerning the interferogram

Have you tried another DEM, e.g. ACE (Auto Download) for a test?

I got a same problem too. Did anyone fix it?image

I have tried with all DEM but the problem is still remaining.

No use . I have tried all the available DEM data.

Once try to save it in “BEAM-DIMAP” format and check if it is working.

What I have observed is that, when ever I use a complete tile for doing terrain correction using gpt and graph builder and want to save the output in “GeoTIFF” format it shows the above error while trying to display the same output file. But if we save the same file in “BEAM-DIMAP” format, it wont show any error and displays the image perfectly.
So, definitely their is some issue while trying to save it in other formats other than “BEAM-DIMAP” format. The technical team @marpet @lveci @mengdahl has to come up with a solution for this problem if I am not wrong.

Yes. I think so. For me, I need to pre-processing and export to netCDF because I am gonna process time-series on MATLAB (need to stack a lot images). Any solutions can help me? I tried HDF5 it works but I can file the variables of LAT LONG & Sigma. GEOTIFF BEAM-DIMAP it works well.
I also tried on Laptop and PC, same problem. so I think these issues come from software.