Land Sea Mask

Dear @marpet and @ABraun Hope you both are doing very great,

The problem is that the Land See Mask should read the Master and the Slave, but in my case it only repeats the Master twice, making it impossible for me to read the correct product name in band math. The graph that follows shows where this problem occurs.

The products are:


It’s important to note that I deleted the cache and restarted SNAP V.9 and the machine. I believe it should correctly read the mst 19 and the slv 31.

Hello Falah,

That’s strange. Products are not allowed to have the same band name twice.
I think that the problem happens before the Land-Sea-Mask. You could remove the last operators and check the output.
An option to work around is to save the graph and then edit the xml manually.

Btw., the I don’t use @marpet account anymore. Now I’m using this one.
See Farewell & Welcome SNAP Community

1 Like

Hello Marco,
Thanks for the update details of your connection.
Many thanks for your rapid reply and helpful advice.
If I make the first read the master, which is the second date, and the first read the slave, which is the first date, as you can see below, the suggestions of removing the last operators still work fine, but the issue now is that it doesn’t take the right master I select. There may be additional suggestions for this.

I’m not working often with SAR data. I think I can’t be of much help here.

I understand that the CreateStack operator does not select the correct master.
I had a quick look into the implementation. There is an auto detection implemented but this doesn’t seem to give you the expected result.
When you manually edit the graph, you have the option to define master band names.
This forces the operator to use the corresponding product as master.

  <node id="CreateStack">
      <sourceProduct refid="Read"/>
<! -- here you can band names, like -->

If you now use the graph from the command line, it might work better.
Loading the modified graph into the GraphBuilder might not help, but worth a try.
Otherwise, I can only delegate you again to @jun_lu or @lveci.
Or maybe @ABraun or @mengdahl or someone else know how to use this properly.

1 Like

Thank you so much for your unwavering support. I eagerly await our colleagues’ response.

Good day Marco,
I found the answer to update the calibration step in the XML file as below. It’s vital to delete any operators following “LandSeeMask” unless you want it to stop working, as you stated previously the source problem comes from the prior step.

To be like,


1 Like