Linux Installation using StaMPS and S-1 data

Hi Thorsten,

I have install StaMPS-4.1-beta in my own machine, I followed your instructions and everything went smoothly,


when I’d like to run, mt_prep_snap I got message, says this command isn’t found, but when I run source ~/StaMPS-4.1-beta/StaMPS_CONFIG.bash
and then run mt_prep_sanp it works,

So, how could I dded up it permanently?


Many thanks

you can include source command in your bash_profile which is then called upon every startup (and includes the folders defined in it).
It is similar to the PATH variable in Windows which allows to call the commands in the listed directories from any location.

But I have never done it, I always manually source the StaMPS config file, because I don’t need it that often.

Yes sure, source manually Stamps.CONFIG.bash,
I also tried to add up the path, but it wasn’t accepted, I don’t know why, but I’ll give a trail again.

Dears I can not run mt_prep_snap or gamma correctly instead of not editing config file well dears i need your help thanks for your courageous help

I have reached here…now what is the problem to proced?

please understand that we cannot easily know the problem by looking at these outputs. There can be many reasons why the script does not find the data in the given folder. But we need more information to help you.

Your screenshots above indicate that the data exported from SNAP lies in

if dem, diff0, geo, rslc are inside this folder, the script should be able to run.
Do they contain the data as required? An example is given here: Workflow between SNAP and StaMPS

Thanks alot @ABraun

I did not get the reason why this error is happening to me…

why are you adding the user folder twice in your command? grafik

Hello @ABraun thanks for replaying… it is the installation directory

but it is different in your shource file: grafik

Dear @ABraun this is the source file

it is hard to understand your setting and think of potential error sources when you switch the configurations which you presented in earlier posts.
Do you have any colleagues who could have a look at your setting? I honestly can’t find the error source like this. Have you checked the contents of the folders exported by SNAP? How many images do you use?

I have used 16 images and i have 15 interferograms previously i have tried to go up to stamp step four unfortunately my computer had formated thats why i am trying to install stamp again…this is to tell the data has no a problem my problem is on installation and running stams

the “segmentation fault (core dump)” error was reported a couple of times. In these three cases, this error was resolved by reinstalling the operating system:

1 Like

Ok Thanks alot @I will do that

Indeed @ABraun you are right.
I am afraid the study area is too large. Could you please say how many burst and subswaths are contained in your AOI and which is the RAM of your computer?

@mdelgado… one subswath and two brusts

After installing successfully all the necessary software packages, StaMPS should work smoothly (except for Step 2 where you have to update your ps_load_initial_gamma.m in the matlab folder under StaMPS-4.1-beta).

Let me share to you my StaMPS_CONFIG.bash and StaMPS_CONFIG.tcsh files as shown below. Just change the username (i.e. ryeramirez in this case) to an appropriate one. Please note that I am using snap2stamps for the pre-processing part.

Below is the screenshot for sourcing StaMPS (and TRAIN).

Again, this should work smoothly if you have the correct directory paths.

I hope this helps.

Thanks also to @ABraun and @mdelgado because I came up with my own documentation about downloading, installing, and running the many software packages for PSI analysis using StaMPS.

1 Like

What about the HW resources?