LTA Download Error: Invalid .zip files


I tried downloading a few dozens of Sentinel-2 Level 1C data from the LTA using R package sen2r, which allows me to batch download. However, some granules were downloaded as files that I can’t extract. Has anyone ever encountered such an issue? Please find some examples of the invalid zip files here.

I tried contacting the Copernicus EO support, and they have made some scenes online from their end and the problem was solved for most of the granules. However, I am still curious about what went wrong and what can be done to avoid the issue to occur again.


does the r script work with checksums to grant that the zip files were completely downloaded?

If some cannot be extracted they might not be fully retrieved during the batch download. Have you checked their file sizes compared to others?

I tried unzipping the first in item on your gdrive and it also failed for me - incomplete archive.

Perhaps you can get then files you’re missing from instead

That first item would be at the folder:

I noticed that the size of the incomplete archives are smaller than the others. I guess this problem was caused by incomplete downloads, but I don’t know what can be done to troubleshoot this because the code work without any issues for other files.

Thanks! I think this is a possible workaround for the problem I encountered for the failed download only occurred several times.

Never looked into this myself… there are several possibilities but it is probably safer to check if the archive is valid via a simple integrity check ( “unzip -t”) would do the job in most systems.

I wonder if the interface between the LTA and the Hub has some sort of problem that doesn’t detect incomplete transfers… Anyone else experienced something like this?

1 Like

I got invalid .zip files for Sentinel-2 LTA. Also having “the same” issue with Sentinel-. In both cases I was using batch downloading using the Copernicus API (wget command at terminal). As you can see in the image, quite a few of the frames give incomplete downloads (too large to just be an error message but too small to be image data e.g. 14MB vs 4GB. Have others experienced this? I have contacted the support desk. Which mirror(s) are others using?

have you tried downloading from the cloud storage posted above instead?

1 Like

They look like Sentinel-1 rather Sentinel-2.

1 Like

Yes, just reporting that the LTA seems to have the same problem for both S1 and S2. Thanks, I will try the google cloud link for Sentinel2. It doesn’t look like Sentinel1 is on google cloud (although it is on google earth engine). Think I will try ASF for S1 next…

Thanks for the report ashlin. But it is better if you report it directly to the Copernicus Hub via This forum is not connected with Copernicus Hub.

1 Like

Thanks @marpet. Yes, I agree. Have done so! Also wondering if others are having similar experiences. Cheers