Mosaicing and resampling error

Hello every body, please help me
I corrected the L1C images to L2A, now I want to mosaic them, but I get this error message

I tried to re-sample them without success. This is an error message that I received

The message “Cannot construct DataBuffer” indicates that you don’t have enough memory to do this processing.
How much memory do you have?
Instead of the Mosaic processor you can try to use the Multi-size Mosaic. This should work without resampling.
Probably you will run into memory issues too.

I have 50 GB of memory in a local disk.
Thank you, I try to multi-size mosaic and I inform you.

Thank you

RAM is not the storage but the computation capacity.

where i will find multi size mosaic tool? can i mosaic sen2core processed sentinal 2a file with this tool?

you can use the search bar to find tools:

The multi-size mosaic tool is here:

You can use it for data of different resolutions, including Sentinel-2 products.

i searched for multi size mosaic but i din’t get it

It is written with a dash (multi-size), just search for “multi”

maybe you should install the latest version of snap:

see i tried the same but din’t got
can you suggest the snap version and link the same download address

come on, it’s not that hard…
(scroll to the bottom: “Preview 5 of SNAP Version 6.0”)

ok thanks but do this beta version has problem in anything

can you specify ‘problem in anything’?

i mean does it have any bug

beta means that some new features are tested but its not an official release. So if you want to explore these new features (such as the multi-size mosaic) you can give it a try.

ok thanks it will let my research give a new kick start:slight_smile:

when i try to multi size mosaic for C2RCC image …it succussfully complete but the image look like this

maybe you entered the output size in degrees: Pixel Size problem in Mosaicing S1A GRD image

1 Like

It work. Thank you very much …your suggestion help me to do further studies