Negative Pixel Spacing in snaphu.conf

I am attempting to InSAR process some R-2 data through to unwrapped phase. I use Snaphu Export, then attempt to run Snaphu in VMplayer as recommended for Windows users. I immediately get a message indicating that my pixel spacing value, dr, is negative. (See below). I have edited the file to make it positive and snaphu will run, but it produces a simple phase gradient across the image.
Any thoughts on why dr is negative?

sar@Mint64 /mnt/hgfs/vmshare/RS2-821_610_Export $ snaphu -f
snaphu.conf Phase_ifg_srd_21Aug2015_10Jun2015.snaphu.img 3644

snaphu v1.4.2

27 parameters input from file snaphu.conf (84 lines total)

pixel spacings dr and da must be positive (meters)

sar@Mint64 /mnt/hgfs/vmshare/RS2-821_610_Export $

I’ll take a look at this next week when I get back into the office.

I too have same problem. Have you got any solution for it?


I am facing same problem with SNAPHU.conf file.

I have uploaded error message as image.

could someone let me know the solution for this…

I think might be the low RAM is the problem,


When I try with sample RADARSAT 2 data provided with tutorial from the link:

noticed that SRTM 3sec data is downloading automatically for sample data set when running graph. and processing successfully without “Negative pixel spacing in snaphu”.

How to overcome this issue, to auto download DEM and execute TopoPhaseRemoval…

I tried with applying aster 30m DEM as well. But no change in result.

could someone look into this…


here i am attaching SNAP error while processing with external DEM (ASTER)

the error is :

" org.esa.snap.core.gpf.OperatorException "

Although having the very good configuration of computer, I am receiving the same error.

can you please describe what data you were using and which steps have been applied?

Hello ABraun,
I am facing this issue while doing the unwraping. Before Unwraping, I did a few operations like Multilookingg, calibration, stacking, interferogram generation. I am using RadarSAT2 Fine Quad data.

For InSAR, you shouldn’t multi-look your data. And as the calibration refers to the backscatter intensity, it is also not relevant.

Did you check if your stack was correctly created and both images match together? Does the interferogram look alright?

Hi. I am new in suing InSAR data here.

I am using Radarsat-2 UltraFine mode dataset as below:

Master: RS2_000916 : Radarsat-2, Desc, UltraFine U22 – 5/5/2020 (GMT)
Slave: RS2_000919 : Radarsat-2, Desc, UltraFine U22 – 29/5/2020 (GMT)

Slant range and azimuth pixel spacings

DR -2.6623568
DA 9.2719291

I got similar issue regarding negative pixel spacing. And I think this happen because using descending mode data. But, if I use ascending data, the value will be positive.

I don’t think this is a problem. You can continue processing.

Yes. I can continue the processing after change the negative value into positive value in CONF file.