New StaMPS release (4.1-beta)

What is the reason of the following error?


inside matlab you have to navigate to the directory where the mt_prep_snap command was executed and all files were written into.

is this the folder, PATCH1? because in the

nothing refers to the result where will be excuted!

In an ideal case, you have two different folders:

  1. one is your SNAP export:
    INSAR_20180105 for example
  2. you create a second one outside that and execute mt_prep there:
    mt_prep_snap 20180105 /path/to/INSAR_20180105

This way, all new files written by matlab are created there. This allows you to have a clean working environment and delete it if you want to start again. #2 is where you navigate in Matlab, it contains the PATCH1 as a subdirectory (don’t navigate in there, stay one level above).

Dear Andy,

I created a new folder and I implement the mt_prep_snap again, but the result as you see out of the folder I created!

mt_prep_snap has to be ran outside matlab (in the shell), it is a Linux script to preprocess the data exported by SNAP. If this was completed correctly, you proceed to open matlab in this folder and start the stamps scripts.


Yes, now I started again to run it in the shell, let see, tremendous thanks to you Andy,

1 Like

I run the command in the shell as you see,

Then I tried to get started in matlab, I got this error,

I’m in the directory in matlab

your PSI folder doesn’t contain PATCH_1 or all the other files created by mt_prep_snap.

This is how it should look like after the execution of the script.

This is the folder which must be used in matlab. Type getparm to see if all data is loaded correctly.
I also suggest not to run steps 1-8 with one command. Execute them one after another to be able to read the output and change the parameters accordingly.

It has but the command was running out of the folder, But now it runs

I totally agree with you, but it was only test.

stamps (2,2)

the same was recently reported here: StaMPS processing error
I don’t have a solution for it. How many images are you using?

Please also have a look at mdelgado’s comments here: Error in SNAP - StaMPS processing of RS2 data: "Index in position 1 is invalid"

I’m using 27 images.

You may try with this function I have modified time ago. I hope it works for you.
ps_load_initial_gamma.m (7.2 KB)

It should be used on the stamps step 1. So before you override the current one on the stamps_v4.1b/matlab/ please make a backup.
Then please run again the command stamps(1,1) so you re-run step1 to use this function

Let me know if this helps


Hello Jose,

Thanks a lot, I followed your instructions, and so far ‘stamps (2,2)’ works fine, I removed all the results and rerun ‘mt_prep_snap’ again, then I run ‘stamps (1,1)’ later on ‘stamps (2,2)’ .

Your modified function worked and solved the issue,

Now I’ll continue, I’ll let you know,



I had been processing with StaMPS 3.1b1 but now I have installed StaMPS 4.1-beta. Is mt_prep_snap the official file or is there another modified one?

Thank you.

Thanks for the information. I will send it to the github distribution so they will have the updated version.

@CFEgildan71 the mt_prep_snap version comes along in the stamps 4.1beta version.


This is the first results wrapped phase, I used (StaMPS 4.1b) I didn’t change any of parameters, the goal is to overcome all the technical issues, thanks go to @mdelgado and @ABraun for their efforts and opinions.


1 Like

good job! Congratulations on sticking to the issue and thanks to @mdelgado for his contribution here. Can you shortly describe what you changed in the matlab script - was it a bug or just covering an exception?

Thanks Andy, I do think there were three bugs, because, when I run debuging and put up break points, the processing was running until the line of bug.