PSI using SNAP-STaMPS workflow in Windows Subsystem for Linux (WSL)

Hi is there any other way to use Snap for PSInSAR analysis without the use of programming?

Hello everyone,

I followed every step on this tutorial but I’ve been having some issues executing the mt_prep_snap command, at first it locate all the files but then i get this msg and it stops.

Patch: PATCH_1
selpsc_patch /home/ikhelif/Downloads/StaMPS-4.1-beta/INSAR_master_data/ pscands.1.ij pscands.1.da mean_amp.flt f 1
file name for zero amplitude PS: pscands.1.ij0
dispersion threshold = 0
width = 0

Anyone got an idea of what’s causing this or how to fix it ? Thanks.

Can you forward the error message with screen shot?

There’s no actual error message it just get stuck there

Have you set the path of StaMPS-4.1-beta/bin in your PC.
May be below post is useful for you check it.

Check this below link also.

Thanks for your replies, I tried both both but unfortunately it still doesnt work.

Here’s a screenshot of what it looks like

Check this below one. Best link given by ABraun.

After reading carefully everything on the screen, I think i figured out what may be causing it to freeze.
Here’s the first lines i get after executing mt_prep_snap:

Amplitude Dispersion Threshold: /0.4
Processing 1 patch(es) in range and 1 in azimuth

/home/ikhelif/Downloads/StaMPS-v4.1-beta/matlab/ps_parms_initial.m: No such file or directory.

I checked the folder and the file is actually there, still the same issue even after re installing StaMPS, Any ideas what I should try next ?

.m files are text, does less /home/ikhelif/Downloads/StaMPS-v4.1-beta/matlab/ps_parms_initial.m display the file? No such file or directory messages can occur when some directory along the path ended up using Unicode “look-alike” characters, for example, ASCII “minus” and “dash” are the same, while Unicode can have different dashes: “em-dash”, “en-dash”, “minus”, etc.

Thanks for your reply, I did rename the Stamps folder without the dash and I no longer get the “No such file or directory” error, yet still stuck at mt_extract_cands

if I understood you correctly, you are not dividing your data into patches. Patch 1 (the only one existing) therefore needs considerable time for processing.
Please add 2 3 at the end of your mt_prep_snap command to divide your data into 6 patches (3 rows, 2 colums). This should speed up the processing a bit.

Thanks but I already tried that but it didn’t work, now with each patch i get this:

selpsc_patch /home/ikhelif/stamps/bin/ pscands.1.ij pscands.1.da mean_amp.flt f 1
selpsc_patch: Command not found.

psclonlat /home/ikhelif/stamps/bin/ pscands.1.ij pscands.1.ll
psclonlat: Command not found.

pscdem /home/ikhelif/stamps/bin/ pscands.1.ij pscands.1.hgt
pscdem: Command not found.

pscphase /home/ikhelif/stamps/bin/ pscands.1.ij
pscphase: Command not found.

this means stamps was not compiled correctly.

Did you run make and make install after downloading the package?

Yes pretty sure the installation went without problem, still can’t figure out why it’s not working

One issue I encountered with StaMPS is that you need gcc 7 and g++ 7. I have an Ubuntu 20.04 VM and the default version is gcc 9 and g++ 9. StaMPS failed to compile properly. I had to downgrade to version 7.

You can check your versions using this command:

this is true. Please see here:

I tried before, it fixed the “segmentation fault” problem but still it won’t run properly, i think i should re install Ubuntu/WSL

Reinstall should be a last resort, and often just gets you back in the same unhappy place.

Have you searched the forums for other reports of your current problem?

If you can provide more details of what doesn’t work someone may recognize the issue an suggest a fix. For starters, there is the original WSL and also WSL2 which uses a real linux kernel and a VM. If your system supports WSL2 and you are using the old WSL it is probably worth trying WSL2. The procedure to change uses wsl.exe and is
time-consuming. You can revert back to WSL if there are new problems with WSL2, but most people prefer WSL2. Also WSL2 will be getting native graphics.

Can you provide full details of your processing steps up to the one that doesn’t work so others can try to reproduce the issue? It is often easiest if you attempt to reproduce a tutorial as others will already have the tutorial data.

As for my personal experience Ubuntu 18.04 LTS is best for StaMPS code. Try it once.