PSI using SNAP-STaMPS workflow in Windows Subsystem for Linux (WSL)

I think none of the time series (either before or after the incident) should contain image pairs which cover the collapse, because you will lose most of the PS. So you either take less images or create a subset which is large enough to be processed.

If you have a small AOI you can skip the tiling option in mt_prep_snap. Instead of 3 2 50 200 you can simply finish the command with 1 1 and no patch overlap.

Actually, after the mt_prep_snap I didn’t put none of these parametres. I added only the 0.42 after the file location ( as in the tutorial of @amirolinxa, where the actual value was 0.40). As for the AOI I have a square area with the size of a side of 40 km.
So you are suggesting to do the pre- process again without including the images after the collapse, maybe considering only the area over the bridge? so, i should follow this order: coregistration > subset> interferogram process. and then the mt_prep_snap with the command ending in 1 1 . ( pelase, correct me if I am wrong)

Definitely he was right. If ur aim is to show the preliminary movements before the sudden collapse, there would be no point to include the images after it. Furthermore, as Ab Braun mentioned it impose unnecessary decoralations on the analysis which results in losing more PS.

I understand what you are saying, and i agree with you. But how is it possible that I still do have some points in the bridge showing the deformation? According to what you are saying, I would expect no points at all over the bridge.

I sometimes even had points over water which were not weeded out because their phase was constant by pure chance.

If you did not enter any row/colum numbers (as you did) I think the script automatically only creates one patch.
And yes, I recommend to coregister, then make a subset and then create the interferograms. You can still leave some area around the bridge (helps to estimate phase contributions), but not necessarily the entire image.


Hi is there any other way to use Snap for PSInSAR analysis without the use of programming?

Hello everyone,

I followed every step on this tutorial but I’ve been having some issues executing the mt_prep_snap command, at first it locate all the files but then i get this msg and it stops.

Patch: PATCH_1
selpsc_patch /home/ikhelif/Downloads/StaMPS-4.1-beta/INSAR_master_data/ pscands.1.ij pscands.1.da mean_amp.flt f 1
file name for zero amplitude PS: pscands.1.ij0
dispersion threshold = 0
width = 0

Anyone got an idea of what’s causing this or how to fix it ? Thanks.

Can you forward the error message with screen shot?

There’s no actual error message it just get stuck there

Have you set the path of StaMPS-4.1-beta/bin in your PC.
May be below post is useful for you check it.

Check this below link also.

Thanks for your replies, I tried both both but unfortunately it still doesnt work.

Here’s a screenshot of what it looks like

Check this below one. Best link given by ABraun.

After reading carefully everything on the screen, I think i figured out what may be causing it to freeze.
Here’s the first lines i get after executing mt_prep_snap:

Amplitude Dispersion Threshold: /0.4
Processing 1 patch(es) in range and 1 in azimuth

/home/ikhelif/Downloads/StaMPS-v4.1-beta/matlab/ps_parms_initial.m: No such file or directory.

I checked the folder and the file is actually there, still the same issue even after re installing StaMPS, Any ideas what I should try next ?

.m files are text, does less /home/ikhelif/Downloads/StaMPS-v4.1-beta/matlab/ps_parms_initial.m display the file? No such file or directory messages can occur when some directory along the path ended up using Unicode “look-alike” characters, for example, ASCII “minus” and “dash” are the same, while Unicode can have different dashes: “em-dash”, “en-dash”, “minus”, etc.

Thanks for your reply, I did rename the Stamps folder without the dash and I no longer get the “No such file or directory” error, yet still stuck at mt_extract_cands

if I understood you correctly, you are not dividing your data into patches. Patch 1 (the only one existing) therefore needs considerable time for processing.
Please add 2 3 at the end of your mt_prep_snap command to divide your data into 6 patches (3 rows, 2 colums). This should speed up the processing a bit.

Thanks but I already tried that but it didn’t work, now with each patch i get this:

selpsc_patch /home/ikhelif/stamps/bin/ pscands.1.ij pscands.1.da mean_amp.flt f 1
selpsc_patch: Command not found.

psclonlat /home/ikhelif/stamps/bin/ pscands.1.ij pscands.1.ll
psclonlat: Command not found.

pscdem /home/ikhelif/stamps/bin/ pscands.1.ij pscands.1.hgt
pscdem: Command not found.

pscphase /home/ikhelif/stamps/bin/ pscands.1.ij
pscphase: Command not found.

this means stamps was not compiled correctly.

Did you run make and make install after downloading the package?

Yes pretty sure the installation went without problem, still can’t figure out why it’s not working