No scene classification processing for 10 m resolution in sc_only mode

I have a warning error when a 10 m resolution is selected in Sen2Cor: “No scene classification processing for 10 m resolution in sc_only mode” , please help me to solve it.

I have had the same prolem…

Any helps?!

Hello to you all
I have this problem also, I can only process in 20,60 resolution anyone know how to solve this issue?

Does some feel responsible for this?

@umwilm, @kraftek, @Nicolas

To my opionion, this is no actual error. As only three bands are available at 10m resolution automatic scene classification cannot be performed. Most Sentinel-2 bands have 20m or less. But only with this increased radiometric information, automatic classification is possible.

@marpet, Sen2Cor is not part of SNAP or S2TBX project, it is part of MPC project and nobody in PMC is in charge of answering the forum for sen2cor even if some MPC peoples are doing this on their free time. Anyway, why didn’t you speak about it on our Tuesday afternoon meeting? I don’t think the forum is the best place for this kind of discussions.

I just wanted to pull someone in who takes care. No need to discuss something. I had it already forgotten at the time of our meeting.

Hello to you all,

I have managed to successfully process to 10 m resolution after having encountered the aforementioned error.
In my case, I solved the problem by reprocessing the 60 m and 20 m resolutions, without activating the Scene Only mode under the processing parameters and ensuring that the default value in Sen2cor Operator Parameters remains FALSE (i.e. Default Value box remains unchecked).

I hope this helps.

Hello mashariki,
I have same issue…I have tried to process it by making the default value box unchecked, but still i was getting the same error.i was not resolving…Please try to help.


If you uncheck the box “scene only” L2A_process should still start to perform. Please make sure that you installed the latest version of sen2cor (2.3.1.)
If you check the box “scene only” you can only select 60m as an output.

Yes, it is sen2cor 2.3.1. it is running for 60m. Many thanks.
But i was unable to find out why this error was coming for a particular dataset. It will be helpful if it was resolved.

Thanks in advance.

did you already adjust path names under Tools > Manage external Tools > sen2cor > edit?

please see here, especially point 4:

I just ran sen2cor for 10m meter and it works fine.
The scene classification is however only done for 20m due to the reasons mentioned above.

I was trying to find out the path of “PYTHON_BIN” from environmental variables. But i could not find any variable with PYTHON_BIN.

where can i find the path for it?

PYTHON_BIN is where you installed Python
C:\Anaconda2\python.exe if you followed the tutorial.

Determining it directly in SNAP replaces its definition in the environment variables.

Many Thanks .I will go through it.

I was unable to resolve the problem…i have given the path of python.exe in the cell of python_bin variable…still the same error was getting.

My apologies for the delay in responding to your concerns. Did you manage to resolve the issue?
If not, please check if your Conda and Sen2cor installations are working via the command prompt using:
For Conda: Type in “conda”
For Sen2cor: L2A_Process --help