Null Pointer Exception when classifying and Operator Exception when reprojecting

Hello all,

I am trying to classify a mosaic-ed (from 3 S2 L1C images) and subset-ted (by a polygon) image. I made the training polygons in SNAP. When classifying, it errors the Null Pointer Exception.

From this thread. It seems the solution is reprojecting to Geographic Lat/Lon (WGS 84). First of all, how to check the projection of the product? It may be already projected in that projection.

When I tried reprojecting it to Geographic Lat/Lon (WGS 84) it errors now: Operator Exception. What should be my next step? Or to solve it?


select the product and click this button grafik
(also loacted in the menu > Analysis > Geo-Coding

It should look like this

Maybe you sould re-project the original data and then create the mosaic.

1 Like

Thanks @ABraun.
I tried looking the Geo-coding information from the original data but has no info in it…
These are Sentinel-2 L1C images.

I was also able to reproject the original data but the output also has no geo-coding information… Seems weird…

I am now mosaicing the reprojected data…

Are all products still saved in the BEAM DIMAP format? Some file formats do not conserve metadata as required.

1 Like

The original products were as they were packaged. The reprojected products are now in BEAM-DIMAP.

very strange, it should then display the Geo-Coding information.
Did you download them from the Copernicus hub and import it via File > Import > Optical > Sentinel-2?

1 Like

I did it that way and the simple File > Open Product. Let me update this thread if I am able to classify them now.