Pins in QGIS


#1

Dear all,

I added some pins over my backscatter image in SNAP and then as pins are below vector layer, then I saved them as shape file.

Then I opened the image in QGIS and also apply pins there but I cannot see pins over my image in QGIS.


Figure 1. Pins in SNAP below vector layer

Figure 2. Pins in QGIS (I applied them as shapefile but I cannot see them)


#2

Hi,

Check the coordinate system of your shapefile (your pin points) and your raster.
Make sure both layers have the same coordinate system


#3

Both have same.


#4

Consider changing the colour and the shape of your pin point in QGIS.
the colour of the pin point is dark, so, if it falls within the dark pixels of your SAR image, you might not be able to see it. Make sure its visible.
(I know that this might sound bit silly )


#5

I tested before but not working.


#6

I do not know what happens.
try and do the following steps again:

  1. load your raw data into SNAP
  2. Choose your preferred coordinate system and re-project the sar image (or leave the default)
  3. Collect pin points over your images.
  4. Export your image into geotiff format
  5. export pin points into shapefile
  6. load both into QGIS

#7

what happens if you change the CRS of the pins to WGS84 in the layer properties? They are probably stored in lat/lon coordinates while the raster is UTM.


#8

I changed to WGS84 but not working. Even I tried it by csv but not working.


#9

change it to WKT (Well Known Text) insted of “Point Coordinates”


#10

@ABraun…Thanks…it works :grinning:


#11

I’m having the same problem, I tried WKT but it doesn’t work in my case.


I vectorized in Qgis a raster file (the selected CRS was always in ESPG32629, WGS84/UTM29N):
imagem
In the following we can see at Qgis an RGB base image (Geotiff)
imagem
After I exported the vectorized data (shp file) and imported to snap multispectral image:
imagem
Then I exported the mask pixels to txt file for later import at Qgis:
imagem
When I import the txt file in Qgis, with the same CRS (ESPG32629, WGS84/UTM29N))
imagem
imagem
The cloud with all the information/pixels are projected to a different CRS (not known, altough at the properties of both layers the txt layer and the raster RGB layer are defined as ESPG32629, WGS84/UTM29N) because they appear in another location different from the RGB raster:
imagem

CRS from Raster:
imagem

CRS from txt layer:
imagem


#12

@Abraun
I think I discovered the problem. The mask pixels exported from snap are being exported in wgs84, even though I was working in another CRS at snap. So if I import the txt file with wgs84 CRS and after reproject on Qgis to the main CRS (in this case it was UTM29N), it works.
Maybe this “problem” could be fixed on a future update.


#13

that is interesting. How did the coordinates of the pins look like and you reproject them in QGIS?


#14

The coordinates looked like this (wgs84/wgs84):


another example from txt file:

At snap it’s the same:
imagem
yet the base of the vectors was different (wgs84/UMT29N):

What should happen (directly from snap, because it worked in the opposite way) without having to reproject again in Qgis, should be this:


#15

you’re right - definitely longitude and latitude.


#16

Abraun,
Snap is doing the input correctly, i.e., it uploads the cartesian X and Y projection of UTM for the 29N region and lets you work on that projection:


But when you export the mask pixels, it only export the elipsoidal/geodesic datum wgs84 (lat / lon).
So if I’m correct, we have to reproject everything again, after the snap txt output.
I think at least we should have a warning when we are exporting, but the optimum should be exporting with CRS we are working on (with no warnings).