Pixels set to NaN when using pixel geocoding

Dear SNAP team,

When using this simple graph (1.4 KB) and pixel geocoding, pixels are replaced by NaNs.

gpt test_ppgc.xml -POLCIsource=S3A_OL_1_EFR____20180601T115221_20180601T115521_20180602T170821_0179_032_009_1620_LN1_O_NT_002.SEN3 -PtargetFolder="out_ppgc" -Ds3tbx.reader.olci.pixelGeoCoding=true


gpt test_ppgc.xml -POLCIsource=S3A_OL_1_EFR____20180601T115221_20180601T115521_20180602T170821_0179_032_009_1620_LN1_O_NT_002.SEN3 -PtargetFolder="out_tpgc" -Ds3tbx.reader.olci.pixelGeoCoding=false


@marpet mentioned that per-pixel geocoding may be inaccurate in high latitude areas but should it fail like this? if yes under which conditions?

I see a lot of similarities between the NaN pixels and the “duplicated” flag.

Yes, this is what I was referring to.
That’s a screen shot from a product when we worked on this issue.
Especially on the left you see the missing pixels.

This is already solved on out development branch.
We want to solve another issue related to pixel-based geocoding.

I don’t want to promise too much, but there might be an update next week.

Dear SNAP team,
Has this issue been resolved?

Yes, this should be fixed. In SNAP 9 it will be fixed. I’m not sure right now if we were able backport all fixes to SNAP 8.x. But I think so.

Hi Marco,
I updated all the plugins in my SNAP8.0.3 and the problem is still there.
Any chance I can bring the fix to SNAP8?
When is SNAP9 scheduled?