Problem in runing mt_prep_gamma_snap

Hello.
i have prepared data in snap and now i want to use ubuntu and stamps for post processing reading the guidelines in STEP i have downloaded mt_prep_gamma_snap and ps_load_initial_gamma.m and also i have installed required libraries for processing but when i run mt_prep_gamma_snap it gives me error that command not found i have attached Screen Shots. kindly guide what could be the problem
thanks

with the release of StaMPS 4.1 you no longer need mt_prep_gamma_snap, you can directly use mt_prep_snap
Explanation here: StaMPS processing error

Just make sure to enter the correct directories for snaphu, triangle, stamps and matlab, we cannot help you finding these. Afterwards, source the file StaMPS_config, so the files and executables inside these directories become available to the shell.

Some report using StaMPS_config.tcsh (instead of .bash) worked better (How to prepare Sentinel-1 images stack for PSI/SBAS in SNAP)

1 Like

Thankyou for your guideline @ABraun … i will check the details

your guideline worked and i am able to run mt_prep_snap …but when the process of patch making is done i run stamps(1,1) it gave another error which is undefined function also i noticed that all files are in kbs. i have attached the SS so kindly check what could be the problem and guide me
thank you.

There is a set path in the MATLAB software interface.
You need to add the path of the matlab folder extracted by StaMPS.zip to the MATLAB software, so that software can search for the functions you use (including stamps (1,1), and of course there are other functions).

2 Likes

Thank you so much for your response and , i will set the path

I was performing stamps(3,3) due to my touch pad problem may be the processing interrupted on Matlab and lines get highlighted with purple color. At the end it gave me an error, i want to ask does it effect the processing in anyway or not? i mean should i rerun stamps(3,3) or should i further process stamps(4,4). I have attached SS.
Thank you.

This should ne no problem, as long as you are seeing the “Finished” output at the end.
What is printed in matlab is just a text output and as long as it does not show an error message, the actual processing workes fine in the background.

1 Like

Got it… Thank you @ABraun

Hi
I have completed stamps(6,6) ,after stamps(5,5) i displayed the results of wrapped images with ps_plot(‘w’) ,At first results appeared but after that it gave an error. now both wrapped and unwrapped ps_plot(‘u’) results are giving error to display. I have attached SS of interface. i have tried it so many times. please have a look
Thank you.

ps_plot('u') is the correct command, but I haven’t seen the SystemError yet

1 Like

when i pasted this to matlab this error came
fl:filesystem:SystemError

As I said, I have not seen this error before, so maybe someone other can help.
I just wanted to confirm that this is the correct syntacs (as you have tried different versions in your screenshot).

1 Like

Okay…thank you

I have run stamps(7,7) but after reading the hints and guideline in STEP forum from experts i came to know that i should rerun stamps(6,6) and stamps(7,7) and i should apply setparm(‘scla_deramp’,‘y’) after running stamps(6,6) but the problem is when i run setparm(‘scla_deramp’,‘y’) it doesn’t execute as it again gave error of undefined function. Is any other way to execute deramp. i have also attached SS. KIndly suggest me about its solution.
Thank you.

you use the wrong quotation marks

setparm('scla_deramp', 'y')
not
setparm(‘scla_deramp‘, ‘y‘)

1 Like

yes you are right… i entered wrong quotation, now i copied your given quotation and it gave me this output on 2nd line.

setparm(‘scla_deramp’, ‘y’)
SETPARM: scla_deramp = y

that is a confirmation that the variable was changed as defined. You can go on.

1 Like

you mean now i should run stamps(7,7) right??

yes, you can go on.

1 Like