Problem of Range Doppler Terrain Correction


I am facing a problem when I process Sentinel1 data in Radar>Geometric>Terrain Correction>Range-Doppler Terrain Correction.

But the result is pretty strange like this

Before this step I finished the processes of Apply the Orbit、Calibrate and Speckle Filtering.

I sincerely appreciate if you can help me understand why the result of Range-Doppler Terrain Correction is error.

Thanks for your help!


there was a problem with the SRTM download, please install all updates:


Thanks for your help.

I was install all updates some time ago.In new version I opened images, but Product Explorer was empty.So I reinstall the SNAP.

2.png1920×1080 71.3 KB

Do you know why this problem occurs?

After re-installing snap, some internal updates might have to be installed again.
After installing all updates, you have to perform terrain correction again.


But the last time I installing all updates, I open original data, the Product Explorer windows is still empty.

Is this my computer problem or am I missing some steps?

Was the original data completely downloaded?
Was the Sentinel-1 data extracted after downloading? You can open the zip file (without extraction) or the manifest file (after extraction).
Did you try to open it via Menu > Import > SAR Sensors > Sentinel-1


I assure that original data was completely downloaded.And I used manifest file.
I also try to open data via Menu >Import >SAR Sensors > Sentinel-1, so I really confuse about this problem.

I am running out of ideas. So the problem is no longer related to Terrain Correction, right?

Have you tried placing the original data into another folder? Maybe something in your cache is messed up.

OK. I will try your suggestion. If this problem is still exist, I will try to change a computer.

Thanks for your help!

Dear @Johnny_wu , this is not related to Terrain correction tool. What is the size of the output product? Also check the pixcel values of your product by moving the cursor.

Dear @Johnny_wu, Have you solved the problem? I had the same problem. I would appreciate it if you could give me some advice. Thank you!

are all updates installed and did you select SRTM 1Sec?

Thank you very much. I solved the problem by using SRTM 1Sec.

In terrain correction, there is a option- Mask out areas without elevation. It should be checked or not?
If its checked image are not display in the window. So tell me the correct step.

this option only applies if you have sea surface areas in your data. If checked, these are removed based on zero elevation in the DEM.

Is it possible that your output is black because you selected SRTM 3Sec? Try SRTM 1Sec instead.

1 Like

1.In Apply orbit file process, there is one option- Do not fail if new orbit file is not found.
So it should be check or not?
Some system it process without checking that option, some are not.

2.Another one it is necessity to do apply orbit file for pre-processing?

They are mostly needed for interferometry. If no error occurs you can leave it checked but you can also skip this step completely.

I am facing problem in sar mosaic.
After mosaic the output like that. Please tell me the exact processes of SAR Mosaic.

Hi, I am not sure if it is the right place to ask. However, i am wondering is there any reference that i can look for how the range-Doppler terrain correction works with DEM in SAR/sentinel-1? I haven’t found any scripts/codes/equations/documents yet regarding this.

1 Like

I think the Guide to ASAR geocoding explains it quite well.
Also Generation of geometrically and radiometrically terrain corrected SAR image products by Loew & Mauser (2007).