Problem with Reproject+Subset S3-OLCI products in batch processing


#1

Hi,
I am trying to run the following graph in batch processing, for a series of S3-L1-OLCI products:


the reprojection is done with Nearest Neig. on UTM(Automatic) and using the following option:
snap64_2018-10-08_11-28-41
The problem I encounter is that the resulting subsets are cut at different extent, do not have the same resolution and neither the same pixel extent:
snap64_2018-10-08_10-59-21
I have tried to invert the processing (Subset -> Reproject -> write) and using Bilinear, but I cannot achieve the expected result: Several subsets from different OLCI acquisitions, cut with the same pixel extents and having exactly the same pixel grid at 300m (original OLCI res.)…I think the problem is in the reprojection/resampling module, which is not “Preserving the original product resolution” properly, any idea why?

Thanks for the support,
Luca


Reprojection woes
#2

This is not necessarily wrong. When you reproject images with the same resolution and image size but different spatial coverages, the sizes of the output images can be different. In turn, when you create subsets based on geographic coordinates, the image sizes of the subsets can be different, too. If you look at the individual subsets, would you say they are not showing the correct result?

Having said this, we have lately discovered problems with reprojecting OLCI images ( Reprojection Creates Ghost Pixels Far Away ), but your issue seems to be different.


#3

Dear TonioF,
I understand your point, but the strange thing is that the “preserve resolution” option is not working the way it should…Look at the generated resolutions of the 3 images of above:
0_2018-10-08_11-22-56
2018-10-08_11-25-34
2018-10-08_11-25-00
(up to 30m difference in their final spatial resolution!)…Why is this happening?

Anyway, I found a solution to my problem:
snap64_2018-10-08_13-25-53
snap64_2018-10-08_13-26-36
-unable “Preserve resolution” option
-Fix the pixel resolution to 300m
-Use bilinear resampling

In this way, I got exactely what I needed: 3 subsets with the same pixel extents and pixel-gridding:

zoom:


snap64_2018-10-08_13-22-17

In my opinion, we should get the same result if we would use the option “preserve resolution”…isn’t that the right?

Luca


S3 WFR values in exported GeoTiff different from DIM
Creating subset of rotated images
Problems with spatial subset
#4

Okay, I see your point. The reason why we have different resolutions is that SNAP estimates the resolution.
However, the resolution of 300 m for a OLCI FR product is just approximate ( https://sentinel.esa.int/web/sentinel/user-guides/sentinel-3-olci/resolutions/spatial ). You can look up the exact resolution of the dataset in the Dataset Attributes of any band in the metadata section.


#5

@TonioF I understand also your point :wink:

However, I think that the “Preserve resolution” option is misleading, because in fact not preserving the original resolution, but it will provide with a different result based on the selected reprojection …


#6

Based on my experience, you should NOT rely on SNAP guessing the right resolution for S3 products. The resolution it finds really varies a lot and is not necessarily symmetric. So always specify the target resolution instead.