Problem with Snappy and error

Yes indeed, you’re right, the letter is in lowercase in the path, however in the folder in uppercase, I copied the address and edited up the path, as you see,


Also I checked up the java, from the java control panel, it says that the latest version is available, I repeated the trial again, However, I got the same results,

I also copied the folder of unzipped python under C: path, but nothing is changed

try : ./configure --with-pydebug
with one dot instead of two dots

Same results,

Right, windows is just a pain.
I can think of 2 solutions you can try.

Solution 1

  • Use **python 2** instead of python 3: If you are interested in running snappy, you can still do that using python 2. In case it is not installed in your system, it can be downloaded from here. At least, python 2 has a windows installer where you do not need to built it from source.

  • Configure snappy with python 2 as we described above. You might need to re-install SNAP and configure it with python 2 first

In case this does not work, we go for

Solution 2

  • Install Cygwin terminal in your PC. Cygwin terminal provided similar functionalities to the ones in Linux. In that way, it might be easier for you to install some python packages. To do that, have a look here and here

  • Also, apart from cygwin, there is another option. WE can install a Linux terminal on windows. Have a look here and here


Thanks a lot for big efforts and fruitful information for all the members of this and outside forum,

I think the py2, I tried it up as you see in the previous posts, but it didn’t work, I need the latest version of python in my machine as well,

But is there any different of configuring SNAP with py2(is created package from 3.7 conda), to the one installed directly and separately for windows and configure with SNAP?

I’ll try up the solution 2 at first and let you know, Again tremendous thanks to you.

when you do ./snappy-conf 'full path of python interpreter for the configuration, do you get any errors on your terminal?

If you like working with anaconda, download anaconda 2, and configure snappy with anaconda 2 as follows:
./snappy-conf 'C:\Users\FALAH FAKHRI\Miniconda2\envs\snappy\bin\python

these guidelines are very useful by the way:

Yes, I did it in here, source of the post

The error on your post was caused when you tried to create a virtual environment with python 3.
You do not need to crate a virtual environment to configure snappy.

Make sure you have the following:

  • python 2 in your system (if you want anaconda, download anaconda 2)
  • SNAP configured with python 2

Once you have the above, then try and configure snappy with the usual way.

This is the results of cygwin,

this results are quite strange.
well, try with python 2 as described on the post above
you might also need to add the snappy path into your system (see here)

SNAP has uninstalled, Anaconda2 is installed, then SNAP is reinstalled and configured with Anaconda2,

in cmd,

./snappy-conf C:\Users\FALAH FAKHRI\Anaconda2\envs\snappy\bin\python

I got this result,

can you use cygwin to do that?
open up cygwin terminal and type:

./snappy-conf C:\Users\FALAH FAKHRI\Anaconda2\bin\python
when you type the above command make sure you are in the right folder (snap/bin)

if this does not work, another alternative might be the following:

Other trial,

The first step for configuring SNAP with python is fine.
FO the second step, you need to find the file snappy-conf. In my case. in linux system this file is located under /home/snap/bin

You can see the snappy-conf on the right. You need to find where this file resides in your system.
You can also do a search on your windows and type the name of the file you are looking for. Windows might identify it

It’s exist within similar folder of yours, but with different extension, *bat

So, should I apply conf as below?

./snappy-conf.bat C:\Users\FALAH FAKHRI\Anaconda2

Or should I add up "snappy-conf.bat " to the path at first?

I applied this, is it correct?

Actually, your python interpreter is not C:\Users\FALAH FAKHRI\Anaconda2. You need the python executable. replace the above with the following: C:\Users\FALAH FAKHRI\Anaconda2\python.exe

I see three options on how to run the snappy-conf file (windows are bit different than linux in terms of files execution).
try the following:

  1. ./snappy-conf.bat C:\Users\FALAH FAKHRI\Anaconda2\python.exe
  2. just type snappy-conf.bat on your terminal
  3. right click on the file -> run as administrator

I think now is installed, but how to check up it?

this step generates the python module snappy. This should be located under .snap/snap-python. make sure you have the folder snappy in there

Yes, it is there, What is the next step?

Now do:

  • cd ‘snappy’
  • type python.exe to start your python interpreter

Now the moment of truth.
from snappy import ProductIO

If this works, you are all set