Problem with StaMPS installation using Linux

if you cannot access/edit the bashrc you can also manually source the config file each time you start working with StaMPS.

mt_prep_snap is called from the linux command line in order to generate the basic working environment required Some notes on this here: How to prepare Sentinel-1 images stack for PSI/SBAS in SNAP

you need triangle and snaphu in any case. If you pre-processed the data with SNAP (e.g. like suggested here)

at best, you leave the initial files exported from SNAP in one folder and create a separate working directory for the StaMPS processing (where you first execute mt_prep_snap) as suggested here. The rest of the folder management is done by the StaMPS scripts alone, as long as you don’t move any files or rename directories :slight_smile:

Hope this helps a bit.

I am facing Problem in installation of StaMPS v4.1b. While writing ‘make’ command under suitable folder, the following message is coming

g++ -O3 -c -o calamp.o calamp.c
g++ -O3 calamp.o -o calamp
g++ -O3 -c -o selpsc_patch.o selpsc_patch.c
g++ -O3 selpsc_patch.o -o selpsc_patch
g++ -O3 -c -o selsbc_patch.o selsbc_patch.c
g++ -O3 selsbc_patch.o -o selsbc_patch
g++ -O3 -c -o cpxsum.o cpxsum.c
g++ -O3 cpxsum.o -o cpxsum
g++ -O3 -c -o pscphase.o pscphase.c
g++ -O3 pscphase.o -o pscphase
g++ -O3 -c -o psclonlat.o psclonlat.c
g++ -O3 psclonlat.o -o psclonlat
g++ -O3 -c -o pscdem.o pscdem.c
g++ -O3 pscdem.o -o pscdem

And then while writing ‘make install’, then this message is coming
make definstall;
make[1]: Entering directory ‘/home/hari/Desktop/PSI_Insar/StaMPS-4.1-beta/src’
dir=…/bin;
if test ! -d $dir; then
echo “Sorry, dir …/bin does not exist, exiting…”; exit; fi;
echo Installing in directory: $dir;
list='calamp selpsc_patch selsbc_patch cpxsum pscphase psclonlat pscdem '; for p in $list; do
echo “Installing (copy): $p”;
cp -f $p …/bin/$p;
done
Installing in directory: …/bin
Installing (copy): calamp
Installing (copy): selpsc_patch
Installing (copy): selsbc_patch
Installing (copy): cpxsum
Installing (copy): pscphase
Installing (copy): psclonlat
Installing (copy): pscdem
make cleaner
make[2]: Entering directory ‘/home/hari/Desktop/PSI_Insar/StaMPS-4.1-beta/src’

  • Removed junk.
  • Removed executables in source dir: /home/hari/Desktop/PSI_Insar/StaMPS-4.1-beta/src.
    make[2]: Leaving directory ‘/home/hari/Desktop/PSI_Insar/StaMPS-4.1-beta/src’
    make[1]: Leaving directory ‘/home/hari/Desktop/PSI_Insar/StaMPS-4.1-beta/src’
    and finally the software is not installed.

Please help me?

My system is x86_64. Is this error because of PC compiler or something else.

With regards

@hariiirs did you manage to overcome the challenge? I’m facing the same problem on Ubuntu 18.04 on wsl.

@ABraun I’m unable to get past make install as it returns the error shared by @hariiirs. I managed to successfully install it the last time though, but I had to reinstall my OS. I tried this on Ubuntu 18.04 running on WSL 1 and Virtualbox on macOS Big Sur. Any assistance will be greatly appreciated.

Thanks!

does it help if you create the bin directory before executing the make command?

I think “…/bin” is referring to the bin directory in StaMPS? I tried to copy this dir to src but it didn’t help. I edited the Makefile by providing the full path to bin, still didn’t help. Then I replaced “…/bin” with “/usr/bin” but it was no good

Looks like it’s not an “error”. I continued with source StaMPS*.bash and looks like everything is working fine.

good to hear. This part sounds alright - so if these scripts were created in the bin directory and you correctly modify the StaMPS_CONFIG file, it should work.

1 Like

YES, @calebaid2000 you are right. Same was with my case. Moreover, bin is the folder under StaMPS only and before executing make command, working directort was changed to StaMPS/src