Problem with StaMPS installation using Linux


#1

I am trying to perform PSI using Envisat images and i have already created PSI export using SNAP 6.0 and have the exported files saved in a file named INSAR Master_date directory. I want to install StaMPS v 3.3b1.I have changed the lat lon file name inside geo file(suggested by katherine)
i am stuck in this two steps: 11/ run mt_prep_gamma from the INSAR_masterdata directory. mt_prep_gamma masterdata /fullpath to the INSAR_masterdata directory 0.4
12/ run matlab and launch StaMPS.

When i try to run the command mt_prep_gamma_snap yyyymmdd /home/fyp/Documents/INSAR_master_date/ 0.4 the “gawk:command not found” is shown and also the error like this image(found it from the topic linux installation using Stamps and S-1 data" ) image note that i have not edited inside the mt_prep_gamma_snap and i am using the changed file uploaded by Feiliu and pasted them in bin and matlab respectively.
I have downloaded the gawk 4.2.0 and extrated it from tar file.but i do not know how to install it or what commands to write to ensure that “gawk:command not found” error is corrected along with the other errors. Also I am not well experienced in using linux and writing commands.
It will be a great help if anyone can explain how to install StaMPS and Matlab in linux for the purpose of PSI.
Also I am following the recommendations from topics discussed in this forum like linux-installation-using-stamps-and-s-1-data,workflow-between-snap-and-stamps. But i am very confused about the steps mentioned in StaMPS manual as I can not figure out what codes i can write that will help me to perform PSI.
I am very new to all these,please help me with solutions.


How to prepare Sentinel-1 images stack for PSI/SBAS in SNAP
#2

Hello,
for disclosure im also very new to this but I fixed the gwak error by installing gawk via apt-get. You have to install the required programs and edit the Paths in the StaMPS_CONFIG.bash (or .tcsh if you don’t want to use the bash shell) file.
The Problem is that you can’t get ROI_PAC right now since the website is down.
https://www.openchannelsoftware.com/
But after this you have have to run the “source” Command to use the Terminal.


Matlab should be easy to install on Ubuntu if you tell me were the Problem is I might be able to assist you.
I can get StaMPS to work but can’t Plot any Data myself (might be the missing ROI_PAC component).
I hope this helps you a bit.


#3

I have now solved the problem of gawk.but i am getting the following errors.but i have changed the config.bash file.


Do i have to install Matlab,doris,ROi_pac,Triangle,snaphu before running mt_prep?Why the calamp error is shown?
Why for every patch file command not found line is shown?
Please help,I am very confused.


#4

I just got it to work without ROI_PAC but I think you need to install at least triangle, snaphu, Doris and Matlab before mt_prep. I tried to replicate your error but count not.
Is your bin Folder complete? Is there an calamp executable file?


#5

how to ensure that my bin folder is complete?existance of which files indicate that?Are you talking about the bin inside staMPS folder?
if you are referring to calamp.exe file then i donot have it.only calamp.c file is what i have.i also have calamp.in file inside bin but i couldnot find calamp.out
I am very new to linux and staMPS also i have very little knowlegde about writing command.please kindly elaborate what steps should i follow from this point onward to perform PSI.


#6

Ok i think you didn’t compile StaMPS in the first Place.
For a start it might be better to download StaMPS again from here:
https://homepages.see.leeds.ac.uk/~earahoo/stamps/
Go to your Download-Folder, right Click “Open in Terminal” (no File/Folder selected).
In Terminal:
tar -xvf StaMPS_v3.3b1.tar.gz
cd StaMPS_v3.3b1/src/
make
make install

You can move the Folder after that if you want. You need to change the “StaMPS_CONFIG.bash” File again. And also replace the two files mentioned here:


Make sure you have triangle, snaphu, Doris and Matlab. And to also change these Paths in “StaMPS_CONFIG.bash”
I just needed to change the follwing paths:
export STAMPS
export DORIS_BIN
export TRIANGLE_BIN
export SNAPHU_BIN

If you have Matlab installed but the command “matlab” in terminal dosen’t work try making a link.
In Terminal:
sudo ln -s [/usr/local/MATLAB/R2018a/]bin/matlab matlab
change the path between [ ] to match your System bevor running the command. And also remove the [ ].


#7

i think i did the steps upto make install,but there might be some error existing.so I will try to install StaMPS again following the instructions here.Thank you for your advice.


#8

By the way can you give me links for doris,snaphu and triangle where there are download links and installation commands.also the lat lon file that i have in geo directory do i need to name it as “master_data” or do i keep its original name i.e. like 20031226.lat?


#9

Dear Len and samanin,
I am getting same error as samanin. If you solve it please let me know.
Thank you.


#10

did you configure StaMPS.bash correclty? The command “mt_extract_cands” is in the Stamps\bin folder the same as where “mt_prep_gamma_snap” is located. If the latter is found by your shell, the first should be callable as well.


#11

Thank you Abraun. After fixing StaMPS.bash I was able to run stamps. But I got error in first step stamps (1,1). When I open INSAR_masterdate folder I cannot find PATCH file and some other files. Please help. Did I messed up the paths.
Thank you.


#12

two things that helped when I got this error:

  1. make sure all data is correctly exported from SNAP.
  2. set ‘gamma’ as your processor in Matlab.

setparm(‘insar_processor’, ‘gamma’)


#13

i couldent fix yhat problem.


#14

Please Help me to install Stamps 4.1


#15

Hi @tarak @thho

I have a similar problem, I think I followed the steps as explained by @thho in his tutorial but I can not fix this error. Can you help me please?

Thank you very much.


#16

you have to exchange the ‘master date’ in your path by the actual date. --> INSAR_20181129


#17

Thanks @ABraun, that day I was processing at 3 a.m. and I can not see my error. I have corrected the error and processed StaMPS.