StaMPS installation in Ubuntu

mt_prep_snap needs to know the date and location of your data exported from StaMPS.

Please see my example here: Linux Installation using StaMPS and S-1 data

I solved the problem. Thank you Andreas.

Best wishes.

1 Like

Dear Volkan, can you share the solution please

Sorry for the late answer, I thought I responded. Even if it’s late, I want to answer. In my case, my codes were missing.

These are the wrong ones:

source /home/volkan/StaMPS-4.1-beta/StaMPS_CONFIG.bash
mt_prep_snap 0.4 3 2 50 200

And these are the true ones:

source /home/volkan/StaMPS-4.1-beta/StaMPS_CONFIG.bash
mt_prep_snap 20180807 /home/volkan/Desktop/PSI/INSAR_20180807 0.42 3 2 50 200

I hope you can easily find the difference.

Best wishes.


Hi there,
I am trying to install StaMPS4.1 in Ubuntu19 but no experience in Linux, after i install ubuntu,copy unzipped stamps4.1 folder to main folder,then type"sudo apt-get install gawk gcc g++ make tcsh" in the terminal(the first step),then “make” ,but
many warnings occurs “no return statement in function returning non-void [-Wreturn-type]”
Could you please, help me to do that?


sorry, I’m not that deep into Linux and only use it for some tasks, so I’m afraid I have no idea what is wrong in your case.

I guess, in your case, the problem is the prerequisites. after you install all the requested libraries, you sould go to src folder and in some cases you have to change install dir from /…/bin to /usr/bin. Then, make install. and sometimes, you should ignore the warnings. after you finished with the isntallation, you have to edit and source the bash or tsch file in the main folder. then each time that you want to run the progrom first you have to source it. it is worthy of not that this package installation is really frustrating. I did it before in a server pc and I dont have access now. I tried to do the same thing in WSL but still I see problems cause it is more complicated. by the way, the follwoing link might be helpful:

Problem with StaMPS installation using Linux


It’s a new artical I’ve never seen, thanks a lot for the advice, I’ll give a try :smiley:

You welcome, I guess I have already done with installation part now.However, I am still stucked in something else. I will inform you if it’s work in that way.

you need a space between the master date and the folder

dears does it make sense the way i edit the bash file

We don’t know where you installed stamps, triangle or snaphu. We cannot tell if these paths are correct.

since i am new to ubuntu and stamps am facing a problem thanks for your help…and continue to give me sugestion

how i can edit the bash file to get mt_prep_snap?

the first line defines where you have installed stamps:
export STAMPS="..."

This line (actually at the end of the script) makes the bin folder inside stamps available to your shell. mt_prep_snap is inside this bin folder, so I don’t know
export PATH=${PATH}:$STAMPS/bin. ...

It is good that snaphu works now. The same should be the case for mt_prep_snap, but I can’t see a reason why it doesn’t work.

also, I don’t think that you need the snap2stamps scripts any longer so you can comment this line out.

Maybe you find someone around you who can directly have a look at your configuration.

Thanks alot @ABraun and i have no a person to help me in near!

Hi there,

I am trying to install StaMPS in Ubuntu, I followed many tutorials but still cannot to install it. Could you please, help me to do that?

I am blocked in the step to make install

Thanks a lot!

Hi, have you solved the problem? i use ubuntu on wsl and get the same error when running ‘make’