Problematic frame with tensorflow when running IdePix

I am running into an error when trying to run IdePix on Sentinel-3 OLCI imagery. It is being run through a Python script, using the snappy library, on a headless version of SNAP (or at least I installed it headlessly) on Ubuntu.

    # A fatal error has been detected by the Java Runtime Environment:
    #  SIGILL (0x4) at pc=0x00007f2c7283fda9, pid=79798, tid=0x00007f2cf5306740
    # JRE version: OpenJDK Runtime Environment (Zulu (8.0_242-b20) (build 1.8.0_242-b20)
    # Java VM: OpenJDK 64-Bit Server VM (25.242-b20 mixed mode linux-amd64 compressed oops)
    # Problematic frame:
    # C  []

The error file from a previous run attached:
hs_err_pid53174.log (182.1 KB)

I imagine this is a situation that might be beyond the scope of SNAP assistance, but thought it was worth a try to pose the problem here.

One idea I had was that the installation of the IdePix via command line was a bit funky. I more or less followed the instructions and advice from this thread, which said that even if the install command results in null and an error message, it was still successfully installed.

Another thing I’ve read reading similar fatal runtime errors is something about memory. However doing free -m on the VM shows about 2,000 free in memory and 4,000 free in swap, so seems sufficient, I thought.

I’m thinking that the tensorflow .so file is erroneous somehow, but I’m not sure how to go about fixing it at the moment.


I found this thread:

It says that the missing AVX instructions support can be the reason.
Maybe you can change the type of CPU in your VM.

I think you’re onto the issue here.

I tried importing tensorflow in Python and got and “Illegal instructions” error. I tried downgrading (to v2.9.3) and now it says “The TensorFlow library was compiled to use SSE4.1 instructions, but these aren’t available on your machine.” I think this is related or the same issue by another name. Looks like since v1.6, AVX is required. Googling these issues came into these thread that also began to reference the AVX issues towards the end:

So I did a search into /proc/cpuinfo and sure enough, don’t see anything that suggests support for avx or avx2.

Ok, so it’s off to IT to see if we can swap out the specs on this VM!


Great! Got IT to swap out the VM specs for something that had AVX support, and it runs now. So that was the issue. Thanks so much!