Problems running PolSARpro v6.0 Biomass Edition

When trying to run PolSARpro v6.0 Biomass Edition I just get a message asking what program should be used to open it. I previously installed all programs suggested (Tcl-Tk, Gimp, ImageMagick, SNAP and Google Earth) but PolSARpro doesn’t run…
Could anyone please help me with this issue?
Thanks a lot.
Enrique

please don’t create duplicates: Unable to run PolSAR 6.0