Problems when opening RapidEye Level 3A data from PlanetExplorer

I have download some RapidEye level 3A imagery from Planet Explorer, when trying to open this in SNAP it is impossible to do so, as SNAP just seems to crash.

The file is in .tif format, and as soon as I select the image to open in the SNAP GUI, a dialogue box pops up asking if I want to open it using a GeoTIFF data product reader or a RapidEye level 3A product reader. Selecting the GeoTIFF reader throws up an error (java.lang.NullPointerException), when I select the RE level 3A product reader it is not possible to load the Image View for the image. I can, for example, click on the navigation and colour manipulation tabs, but nothing happens. SNAP seems to always be stuck on the “Opening image view” step. The image is not large at all (<200 MB), so it can’t be the size. I am using the most recent version of SNAP (6.0 for Windows).

Can this be fixed, please? I think I have seen a similar post about this issue, but as far as I can tell, no solution was ever found (RapidEye imagery from Planet Explorer). I have the same issue whether I import the image or just try to open it.

Thank you!

Did you try to select the XML or the ZIP file instead of single GeoTIFFs?
This is a preselection if you open it via the RapidEye reader:

It should be in the folder and something like:

My data was also downloaded from the Planet Explorer and it works like charm:

1 Like

Sounds like SNAP is not properly recognizing this format. @obarrilero could you check? The product spec is over here:

maybe it additionally depends on product versions of RapidEye but I was never able to reduce this issue and with Level3A products

I just tried 23 scenes ranging from RE1 to RE5 (all Level3A, between 2009-2014) and all loaded properly.


1 Like

The data files I have are of the format *_RE3_3A_Analytic.tif, is SNAP able to read that kind of data?

I also tried opening the metadata xml file and the zip file for a few scenes, I couldn’t get any images to display.

I see - this is a different (relatively new) product: Analytic Ortho Tile
Do you have the chance to download the Basic product instead?

I will check if I can get the basic product instead and let you know how I get on :slight_smile:
Meanwhile, are there any plans to make SNAP able to read Analytic Ortho Tile products?

are there any sample data for this kind of product?

I don’t think there is any sample imagery, however I have asked and I would be able to give you a scene (or a few more, if necessary) to see if you can develop a reader for SNAP, on the understanding that you cannot use it commercially (Planet Explorer T&Cs) and you delete it once you have used it.

Does that sound possible? If so, is there somewhere I can upload the data securely?

oh I am not a developer, I was just curious about the data :slight_smile:
But maybe the others can answer if it is feasible.

@marpet, is this something that can be fixed?

It can be fixed depending on the number of SNAP users requesting support for that product. BTW you could also inquire from Planet if they intend to develop SNAP-readers for their products(?). Some other data producers including Airbus and ICEYE are doing exactly this.

I completelly agree with @mengdahl . In any case, it would be very useful if you can share the example product with me and @kraftek (both s2tbx developers) in order to estimate the effort for updating the reader.

What would be the best way to share the image with you?