Radiometric & Geometric Correction Workflow

this could be new since SNAP version 6. In that case it is no harm to put the calibration to B= at the very beginning.

Yes , I have tried the same. So first Calibration to beta0 then deburst and orbit file a=… but i could not perform thermal noise removal it says beta0_VV does not contain thermal noise… So now Applying Speckle filtering… it is consuming lot of time to do speckle filter…

Speckle filtering is optional. You can also generate subsets with TOPS Split first.

Thank you ABraun, i will give a try.

Is it fine, if i firstly subset the GRD data(to my AOI) and then apply the above mentioned steps or should i first perform all these steps and then subset it at last.

Both should be fine. If you need to have an exact subset based on coordinates, you can apply the orbit file first.

1 Like

Did you know any scientific papers for those steps at GRD or SLC products?

1 Like

When applying the Calibration or ThermalNoiseRemoval Operators to a S1 SLC dataset (complex data),
the result obtained is no longer complex valued. Is that true, I can not save in complex data or you know some ways to work around to save in complex format?

Use the checkbox ‘complex output’ in the calibration module.

For Sentient SLC

  1. Read
  2. ThermalNoise Remove
  3. Calibation (Save as complex Output)
  4. TOPSAR-Deburtst
  5. Terrain-Correction
  6. Write (Would like to complex (i and q)

Got errors as I posted

if you calibrate (to complex) before thermal noise removal you can probably perform the whole process and select “output complex data” in the terrain correction step as well.

I saved output in complex data as you see on picture,
the result obtained is no longer complex valued as you see on box

as you can See, Sigma is already the input of Terrain Correction. So the complex information must have been lost in the previous steps already. Did you perform these steps manually for once to theck the intermediate products of each step?

If I take out the ThermalNoise Remove, it will perform output as complex data as I want.
But I perform TheramalNoise Remove step as picture I provided, the result obtained is no longer complex valued.

I also perform manual step by step

  1. Read
  2. Calbration (save as complex data)
  3. ThermalNoise Remove (do not see the choice to save on complex data or Sigma data)

Here is output looklike

Is it an option to skip the thermal noise removal then?

if I skip to Thermal Noise the output is have lines

That is some serious noise…
Is it an option to take another image instead?